Bug 14079 - No text in Safari 3 Beta for Windows (don't attach your fonts.plist, we understand the problem)
Summary: No text in Safari 3 Beta for Windows (don't attach your fonts.plist, we under...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: PC Windows XP
: P2 Normal
Assignee: Nobody
URL: http://discussions.apple.com/thread.j...
Keywords: InRadar, ReviewedForRadar
: 14290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-06-11 17:07 PDT by Adam Roben (:aroben)
Modified: 2008-02-01 07:50 PST (History)
5 users (show)

See Also:


Attachments
Fonts.plist (66.29 KB, text/plain)
2007-06-11 17:23 PDT, mart pich
no flags Details
No Fonts (100.08 KB, image/jpeg)
2007-06-11 17:25 PDT, mart pich
no flags Details
Fonts.plist (68.62 KB, application/octet-stream)
2007-06-11 17:28 PDT, Meli
no flags Details
Fonts.plist (68.88 KB, application/xml)
2007-06-11 17:48 PDT, Jack Wilcox
no flags Details
Fonts.plist (75.59 KB, text/plain)
2007-06-11 17:50 PDT, janeway216
no flags Details
Safari, sans text (248.17 KB, image/png)
2007-06-11 17:54 PDT, janeway216
no flags Details
Dgrin forums with Safari - note missing text (241.89 KB, image/jpeg)
2007-06-11 18:02 PDT, Paul Mulner
no flags Details
Dgrin forums with IE7 - no missing text (241.89 KB, image/jpeg)
2007-06-11 18:02 PDT, Paul Mulner
no flags Details
Bugzilla with Safari - Note missing text (178.37 KB, image/jpeg)
2007-06-11 18:03 PDT, Paul Mulner
no flags Details
Bugzilla with IE7 - No missing text (217.82 KB, image/jpeg)
2007-06-11 18:04 PDT, Paul Mulner
no flags Details
Fonts.plist from failed Safari installation (68.20 KB, application/octet-stream)
2007-06-11 18:04 PDT, Laura Fisher
no flags Details
Fonts.plist (68.04 KB, text/plain)
2007-06-11 18:05 PDT, Paul Mulner
no flags Details
Fonts.plist from a working computer for comparison (36.93 KB, application/xml)
2007-06-11 18:05 PDT, Jack Wilcox
no flags Details
Fonts plist (64.49 KB, application/octet-stream)
2007-06-11 18:37 PDT, Jeff Moulton
no flags Details
Fonts.plist - text missing from web pages (26.65 KB, text/plain)
2007-06-11 18:58 PDT, Timo Jutila
no flags Details
My fonts.plist attached as requested (66.29 KB, text/plain)
2007-06-11 19:00 PDT, Todd Walker
no flags Details
Fonts.plist - some fonts missing in web pages (bold fonts?) (49.57 KB, text/plain)
2007-06-11 19:19 PDT, Yann Duguay
no flags Details
Fonts.plist from computer not showing UI text (66.65 KB, application/xml)
2007-06-11 19:23 PDT, Cody 'codeman38' Boisclair
no flags Details
fonts.plist (74.58 KB, application/octet-stream)
2007-06-11 19:32 PDT, Neil Hinkle
no flags Details
fonts plist file (67.36 KB, application/octet-stream)
2007-06-11 19:41 PDT, alan phillips
no flags Details
pictures of problem (333.93 KB, application/pdf)
2007-06-11 19:48 PDT, alan phillips
no flags Details
Another fonts.plist - 1471 fonts (59.93 KB, application/octet-stream)
2007-06-11 20:43 PDT, Joel
no flags Details
Fonts,plist file as requested (69.16 KB, application/octet-stream)
2007-06-11 20:52 PDT, Bob Lawrence
no flags Details
fonts.plist (68.24 KB, application/octet-stream)
2007-06-11 21:16 PDT, kaiviti
no flags Details
Fonts pls file (66.01 KB, application/octet-stream)
2007-06-11 21:34 PDT, Brian Tiede
no flags Details
screenshot of the problem (75.28 KB, image/jpeg)
2007-06-11 21:35 PDT, Brian Tiede
no flags Details
Fonts.plist (65.61 KB, application/octet-stream)
2007-06-11 23:01 PDT, ia
no flags Details
Fonts.plist (10.25 KB, application/octet-stream)
2007-06-11 23:46 PDT, Salvatore Pecoraro
no flags Details
Fonts.plist (79.32 KB, text/xml)
2007-06-12 03:52 PDT, John Setlik
no flags Details
Screenshot of problem (129.60 KB, image/pjpeg)
2007-06-12 03:56 PDT, John Setlik
no flags Details
Safari Fonts.plist (73.87 KB, text/plain)
2007-06-12 04:14 PDT, Ashley Lumsden
no flags Details
as requested (69.14 KB, text/xml)
2007-06-12 05:06 PDT, Tom Scholes
no flags Details
Large set of fonts (66.19 KB, text/plain)
2007-06-12 05:39 PDT, Robert M. Soran
no flags Details
No text on Safari broswer 3.0 beta (64.08 KB, text/plain)
2007-06-12 07:12 PDT, aniko
no flags Details
Font.plist (70.47 KB, text/plain)
2007-06-12 08:57 PDT, polartek
no flags Details
Fonts.plist (60.73 KB, application/octet-stream)
2007-06-12 09:46 PDT, Sabrina W
no flags Details
Fonts.plist (20.23 KB, application/octet-stream)
2007-06-12 11:20 PDT, Marc Henkel
no flags Details
Italian font list (8.35 KB, text/plain)
2007-06-12 15:14 PDT, Upanisad
no flags Details
My font.plist from a french windows XP SP2 (11.50 KB, application/xml)
2007-06-13 11:21 PDT, Manoel
no flags Details
Fonts.plist (WinXPSP2 FI) (16.88 KB, text/plain)
2007-06-14 07:08 PDT, Mandibela
no flags Details
Image illustrating the problem (missing BOLD fonts in render) (131.36 KB, image/png)
2007-06-14 07:52 PDT, Mandibela
no flags Details
requested font file (63.87 KB, application/octet-stream)
2007-06-14 09:14 PDT, Kathy Titley
no flags Details
screenshot of safari app in windows - all fonts missing (190.13 KB, image/jpeg)
2007-06-14 09:17 PDT, Kathy Titley
no flags Details
Fonts.plist (66.58 KB, text/plain)
2007-06-16 08:33 PDT, upekshapriya
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2007-06-11 17:07:00 PDT
(Please excuse this misuse of the WebKit bugzilla)

Some users have reported that after installing the Safari 3 Beta for Windows, no text is visible, either in the application or in web sites, or in both.

If you upload your Fonts.plist file, please describe whether text is invisible only in the application, or in web pages, or in both.
Comment 1 mart pich 2007-06-11 17:23:14 PDT
Created attachment 14940 [details]
Fonts.plist

Here is the file, as requested.
Comment 2 mart pich 2007-06-11 17:25:08 PDT
Created attachment 14941 [details]
No Fonts

No fonts for menus and web pages. Safari was installed on XP SP2 vanilla
Comment 3 mart pich 2007-06-11 17:26:09 PDT
No fonts for menus and web pages. Safari was installed on XP SP2 vanilla
Comment 4 Dave Hyatt 2007-06-11 17:27:58 PDT
Appears to be an issue with a font name causing the plist to end up being invalid XML.  The bad font is b5hollow
Comment 5 Meli 2007-06-11 17:28:58 PDT
Created attachment 14942 [details]
Fonts.plist

No fonts are available on my Safari, either in menu bars, address bars, or the web page itself. One time, however, I accidentally navigated to the NY Times website, where the font displayed fine.
Comment 6 Meli 2007-06-11 17:30:16 PDT
Installed on Windows XP, SP2.
Comment 7 Dave Hyatt 2007-06-11 17:34:15 PDT
The first list only seems to go to G.  Like we had a problem writing out H-Z.

Comment 8 Dave Hyatt 2007-06-11 17:35:57 PDT
Both font files are enormous.  Maybe the common issue is having a huge number of fonts installed.

Comment 9 Dave Hyatt 2007-06-11 17:44:11 PDT
Another crazy theory.  If CG hangs on to HFONTs, we could be hitting the theoretical GDI limit, but that would take a whole lot of fonts (like 65000).

Comment 10 Jack Wilcox 2007-06-11 17:48:43 PDT
Created attachment 14943 [details]
Fonts.plist

No text in application, but text does appear in webpages.
Comment 11 janeway216 2007-06-11 17:50:31 PDT
Created attachment 14944 [details]
Fonts.plist

Fonts.plist as requested on the Apple support thread. PC compatible running XPSP2. 1941 total fonts installed.
Comment 12 Dave Hyatt 2007-06-11 17:53:34 PDT
Yeah all these lists are truncated.
Comment 13 janeway216 2007-06-11 17:54:09 PDT
Created attachment 14945 [details]
Safari, sans text

Safari window, textless. XPSP2.
Comment 14 janeway216 2007-06-11 17:55:20 PDT
Comment on attachment 14944 [details]
Fonts.plist

Text is invisible both on web pages and in the application itself. I've included a screenshot of how it appears.
Comment 15 Meli 2007-06-11 17:55:28 PDT
Would that be a problem with the number of fonts we have, or a problem in Safari that can be fixed?
Comment 16 Adam Roben (:aroben) 2007-06-11 18:02:04 PDT
Thank you to everyone who has uploaded so far. The file of interest is:

(Windows XP)
C:\Documents and Settings\<username>\Local Settings\Application Data\Apple Computer\Safari\Fonts.plist

(Vista)
C:\Users\<username>\AppData\Local\Apple Computer\Safari\Fonts.plist
Comment 17 Paul Mulner 2007-06-11 18:02:06 PDT
Created attachment 14946 [details]
Dgrin forums with Safari - note missing text
Comment 18 Paul Mulner 2007-06-11 18:02:50 PDT
Created attachment 14947 [details]
Dgrin forums with IE7 - no missing text
Comment 19 Paul Mulner 2007-06-11 18:03:29 PDT
Created attachment 14948 [details]
Bugzilla with Safari - Note missing text
Comment 20 Dave Hyatt 2007-06-11 18:03:41 PDT
(In reply to comment #15)
> Would that be a problem with the number of fonts we have, or a problem in
> Safari that can be fixed?
> 

It's our fault.  No worries. :)
Comment 21 Paul Mulner 2007-06-11 18:04:11 PDT
Created attachment 14949 [details]
Bugzilla with IE7 - No missing text
Comment 22 Laura Fisher 2007-06-11 18:04:30 PDT
Created attachment 14950 [details]
Fonts.plist from failed Safari installation
Comment 23 Paul Mulner 2007-06-11 18:05:06 PDT
Created attachment 14951 [details]
Fonts.plist
Comment 24 Jack Wilcox 2007-06-11 18:05:33 PDT
Created attachment 14952 [details]
Fonts.plist from a working computer for comparison

I previously posted fonts.plist from my desktop that had the problem of no text in the application. This attachment is from my laptop that was not experiencing the problem. My desktop has over 1300 fonts installed, while my laptop has only about 400. I copied fonts.plist from the laptop to the desktop that was having the problem and now Safari works fine on the desktop. Text appears everywhere it should.
Comment 25 Laura Fisher 2007-06-11 18:06:04 PDT
Comment on attachment 14950 [details]
Fonts.plist from failed Safari installation

No text in menu, some text in web sites.  I tried the various 'fixes' with no luck - but one of those fixes was to install the Lucida fonts in Windows font directory, which I did.
Comment 26 Jeff Moulton 2007-06-11 18:37:37 PDT
Created attachment 14953 [details]
Fonts plist

Windows XP on a Dell Inspiron 6000 with about 1300 fonts installed.  I am unable to see any fonts displayed in both web pages and in menus.
Comment 27 Adam Roben (:aroben) 2007-06-11 18:43:01 PDT
Our current best guess at the cause of this problem is that some of our font code is unable to handle a large number (>850) of installed fonts. A possible workaround would be to close Safari, reduce the number of installed fonts below this limit by moving some fonts out of C:\Windows\Fonts, and delete the Fonts.plist file, which is located here:

(Windows XP)
C:\Documents and Settings\<username>\Local Settings\Application Data\Apple
Computer\Safari\Fonts.plist

(Vista)
C:\Users\<username>\AppData\Local\Apple Computer\Safari\Fonts.plist
Comment 28 Dave Hyatt 2007-06-11 18:43:53 PDT
<rdar://problem/5264111>
Comment 29 Timo Jutila 2007-06-11 18:58:25 PDT
Created attachment 14954 [details]
Fonts.plist - text missing from web pages

Attached is a Fonts.plist from a 64-bit Vista installation, with less than 400 fonts. Safari looks ok, but pages are missing text.
Comment 30 Todd Walker 2007-06-11 19:00:40 PDT
Created attachment 14955 [details]
My fonts.plist attached as requested

No text in menus or webpages. Windows XP SP2
Comment 31 Yann Duguay 2007-06-11 19:19:26 PDT
Created attachment 14956 [details]
Fonts.plist - some fonts missing in web pages (bold fonts?)
Comment 32 Cody 'codeman38' Boisclair 2007-06-11 19:23:08 PDT
Created attachment 14957 [details]
Fonts.plist from computer not showing UI text

The machine in question had over 1500 fonts installed, some just randomly installed, some required for other programs such as WordPerfect to function correctly.

Screenshot can be found at:
http://www.flickr.com/photos/codeman38/541331963/
Comment 33 Cody 'codeman38' Boisclair 2007-06-11 19:26:04 PDT
Also worth noting is that, in some of these plist files, one font file is enumerated several times because it goes by several different names.  (Verdana Bold versus Verdana-Bold, for instance.)
Comment 34 Neil Hinkle 2007-06-11 19:32:22 PDT
Created attachment 14958 [details]
fonts.plist
Comment 35 alan phillips 2007-06-11 19:41:52 PDT
Created attachment 14959 [details]
fonts plist file

Also find the screen shot of my current experience
Comment 36 alan phillips 2007-06-11 19:48:34 PDT
Created attachment 14960 [details]
pictures of problem
Comment 37 Joel 2007-06-11 20:43:38 PDT
Created attachment 14961 [details]
Another fonts.plist - 1471 fonts

Bound to affect most trying Safari as many graphic designers and web builders will want to see how their stuff renders in Safari without the use of a Mac.  Good luck ...
Comment 38 Bob Lawrence 2007-06-11 20:52:16 PDT
Created attachment 14962 [details]
Fonts,plist file as requested

No Text in Safari menus or webpages
Comment 39 kaiviti 2007-06-11 21:16:09 PDT
Created attachment 14963 [details]
fonts.plist

fonts not showing in menus. couldnt get to open any urls as safari kept crashing, so cant tell if fonts would show on actual webpages
Comment 40 Brian Tiede 2007-06-11 21:34:39 PDT
Created attachment 14964 [details]
Fonts pls file
Comment 41 Brian Tiede 2007-06-11 21:35:34 PDT
Created attachment 14965 [details]
screenshot of the problem
Comment 42 ia 2007-06-11 23:01:16 PDT
Created attachment 14966 [details]
Fonts.plist

For this thread:
http://discussions.apple.com/message.jspa?messageID=4709357#4709357

As far as I know I only get blank text on webpages. (Not all webpages, but most of them.)
Comment 43 Salvatore Pecoraro 2007-06-11 23:46:19 PDT
Created attachment 14967 [details]
Fonts.plist

follow this message 
http://discussions.apple.com/message.jspa?messageID=4709083#4709357
Comment 44 John Setlik 2007-06-12 03:52:16 PDT
Created attachment 14973 [details]
Fonts.plist

Looks like sites using Verdana do not show up--there are likely others.  Also, Verdana and Times New Roman previews are not rendered when choosing fonts preferences...
Comment 45 Tino Didriksen 2007-06-12 03:56:03 PDT
I have the no-text-anywhere problem as well, but the file Fonts.plist does not exist on my WinXP SP2 system. Checked in "C:\Documents and Settings\Tino Didriksen\Local Settings\Application Data\Apple Computer\Safari" and "C:\Documents and Settings\Tino Didriksen\Application Data\Apple Computer\Safari" and ran a global search for it. Nowhere to be found.

I have 1331 fonts installed, some with fancy names such as el_26font_brush_21_29.ttf's "<El&Font! Brush>" (yes, <> in the visual name).
Comment 46 John Setlik 2007-06-12 03:56:58 PDT
Created attachment 14974 [details]
Screenshot of problem
Comment 47 Ashley Lumsden 2007-06-12 04:14:37 PDT
Created attachment 14975 [details]
Safari Fonts.plist

XP SP2 Fonts list as requested. I have no text in the application or in web pages
Comment 48 Ashley Lumsden 2007-06-12 04:17:34 PDT
Created attachment 14976
Comment 49 Tom Scholes 2007-06-12 05:06:34 PDT
Created attachment 14978 [details]
as requested

Vista machine. 565 fonts. No text on interface, not much on webpages either.
..T
Comment 50 Robert M. Soran 2007-06-12 05:39:13 PDT
Created attachment 14979 [details]
Large set of fonts

FYI, as requested
Regards 
Robert M. Soran
Comment 51 aniko 2007-06-12 07:12:50 PDT
Created attachment 14980 [details]
No text on Safari broswer 3.0 beta
Comment 52 polartek 2007-06-12 08:57:35 PDT
Created attachment 14981 [details]
Font.plist

602 fonts listed in font folder.
Comment 53 polartek 2007-06-12 08:58:55 PDT
Created attachment 14982


Missing text issue - Screen grabs from Windows version - MS Word doc.
Comment 54 Sabrina W 2007-06-12 09:46:18 PDT
Created attachment 14983 [details]
Fonts.plist
Comment 55 Marc Henkel 2007-06-12 11:20:43 PDT
Created attachment 14985 [details]
Fonts.plist
Comment 56 Upanisad 2007-06-12 15:14:41 PDT
Created attachment 14986 [details]
Italian font list

This is from a clean Windows XP italian installation I use for web development testing. Note that no application is installed, except for browsers! So definitely it has nothing to do with "too many fonts". Also note that the problem seems to be common to every italian user (and french and swedish... basically many non-english Windows localized versions).
Text is invisible only in web pages when a bold or italic font is required for rendering (that is, not only B or STRONG or font-weight:bold, but also H1 and headings!)
Comment 57 hilmar 2007-06-13 09:41:30 PDT
Bug is related to the number of fonts in the fonts dir.
At first i had 2600+ fonts in my c:\windows\fonts directory (winxppro) after decreasing (read deleting) this to below the 555 mark solved the 'issue'.

557 gives partial text

h.
Comment 58 Manoel 2007-06-13 11:21:23 PDT
Created attachment 15004 [details]
My font.plist from a french windows XP SP2

C:\Documents and Settings\Godzil\Local Settings\Application Data\Apple Computer\Safari
Comment 59 Manoel 2007-06-13 11:25:01 PDT
> C:\Documents and Settings\Godzil\Local Settings\Application Data\Apple
> Computer\Safari
> 
Wrong copypaste.. :

I have some probleme with fonts but not no text on gui or webpage, but only on some part of webpages (I will add a screenshot)
Comment 60 Manoel 2007-06-13 11:31:42 PDT
Created attachment 15005


This is what I get with safari (up) and what Firefox give me (and is correct on font rendering) (down)

I took this example because it's one of my one webpage, but it's happen on a lot of pages, like here for example.
Comment 61 Nick McClellan 2007-06-13 17:43:52 PDT
I was experiencing this bug, no text whatsoever (in the GUI or on the inital homepage that uses the font).

Spent a while tracking down the problem, and came up with a workaround.

Looks like the fonts "Lucida Grande" and "Lucida Grande Bold" aren't getting installed on my machine for whatever reason (Checked with Filemon from MS\sysinternals). I extracted the fonts from the MSI installer and copied them to the fonts folder manually. I then deleted my Fonts.plist and the Cache.db to force safari to rebuild the font list. After that, all was good.

Steps for workaround:
1) Get a hold of "Lucida Grande.ttf" and "Lucida Grande Bold.ttf"
2) Copy them to C:\WINDOWS\Fonts\
3) Delete "Fonts.plist" and "Cache.db" from C:\Documents and Settings\{User Name}\Local Settings\Application Data\Apple Computer\Safari\
Comment 62 hilmar 2007-06-14 04:10:33 PDT
(In reply to comment #61)
> I was experiencing this bug, no text whatsoever (in the GUI or on the inital
> homepage that uses the font).

> force safari to rebuild the font list. After that, all was good.
> 
> Steps for workaround:
> 1) Get a hold of "Lucida Grande.ttf" and "Lucida Grande Bold.ttf"
> 2) Copy them to C:\WINDOWS\Fonts\
> 3) Delete "Fonts.plist" and "Cache.db" from C:\Documents and Settings\{User
> Name}\Local Settings\Application Data\Apple Computer\Safari\

I did try this sollution as well, no resolution for me. i used the ttf's from  
C:\Program Files\Safari\Safari.resources. Deleting fonts (from 2600+) to a threshold below the 555 does the trick for me.

h.

Comment 63 Tore B. Krudtaa 2007-06-14 04:33:08 PDT
Howdy....

I had same problem with some text missing on a site (actually lots of sites).
Did some tests and found this:

if I change 
font-weight:bold;
to
font-weight:normal;

then the missing text on the page is visible.

There also seem to be a problem with non bold text looking to bold.

Hope you can get this fixed asap, since this is making this Safari 3 Windows Beta pretty much useless....

Cannot belive the apple marketing dep. allowed it to be released to endusers in it's current state....
Comment 64 Mandibela 2007-06-14 07:08:24 PDT
Created attachment 15021 [details]
Fonts.plist (WinXPSP2 FI)

From a fully-patched version of a finnish WinXP
Comment 65 Mandibela 2007-06-14 07:09:38 PDT
Comment on attachment 15021 [details]
Fonts.plist (WinXPSP2 FI)

I have the missing BOLD -fonts bug, CSS and other fonts do not show.
Comment 66 Mandibela 2007-06-14 07:52:40 PDT
Created attachment 15022 [details]
Image illustrating the problem (missing BOLD fonts in render)
Comment 67 Kathy Titley 2007-06-14 09:14:49 PDT
Created attachment 15023 [details]
requested font file
Comment 68 Kathy Titley 2007-06-14 09:17:09 PDT
Created attachment 15024 [details]
screenshot of safari app in windows - all fonts missing

I am missing fonts in both the app and the web content. Clicking on spider hangs the application. Trying to access menu also hangs application.
Comment 69 Kelly Cunningham 2007-06-15 09:57:05 PDT
If you install the update released on June 12th, it will not fix the font problem (if you are experiencing it). You will need to edit your Fonts.plist file once the newly patched browser starts once and rebuilds the Fonts.plist file. Here is a snip of what I add to the top of the Fonts listed in this file which has solved missing text and strange text issues:

		&lt;key&gt;Verdana&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\verdana.ttf&lt;/string&gt;
		&lt;key&gt;Verdana Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\verdanab.ttf&lt;/string&gt;
		&lt;key&gt;Verdana Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\verdanai.ttf&lt;/string&gt;
		&lt;key&gt;Verdana Bold Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\verdanaz.ttf&lt;/string&gt;
		&lt;key&gt;Tahoma Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\tahomabd.ttf&lt;/string&gt;
		&lt;key&gt;Tahoma&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\Tahoma.TTF&lt;/string&gt;
		&lt;key&gt;Tahoma Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\Tahomabd.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebuc.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucbd.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet Bold Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucbi.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucit.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet MS&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebuc.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet MS Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucbd.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet MS Bold Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucbi.TTF&lt;/string&gt;
		&lt;key&gt;Trebuchet MS Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\trebucit.TTF&lt;/string&gt;
		&lt;key&gt;Lucida Grande&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\Lucida Grande.ttf&lt;/string&gt;
		&lt;key&gt;Lucida Grande Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\Lucida Grande Bold.ttf&lt;/string&gt;
		&lt;key&gt;Times New Roman&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\times.ttf&lt;/string&gt;
		&lt;key&gt;Times New Roman Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesbd.ttf&lt;/string&gt;
		&lt;key&gt;Times New Roman Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesi.ttf&lt;/string&gt;
		&lt;key&gt;Times New Roman Bold Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesbi.ttf&lt;/string&gt;
		&lt;key&gt;Times&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\times.ttf&lt;/string&gt;
		&lt;key&gt;Times Bold&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesbd.ttf&lt;/string&gt;
		&lt;key&gt;Times Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesi.ttf&lt;/string&gt;
		&lt;key&gt;Times Bold Italic&lt;/key&gt;
		&lt;string&gt;C:\WINDOWS\Fonts\timesbi.ttf&lt;/string&gt;
		
I hope this helps!

Comment 70 upekshapriya 2007-06-16 08:33:02 PDT
Created attachment 15080 [details]
Fonts.plist

This is my fonts.plist file - as requested
Comment 71 Kelly Cunningham 2007-06-17 07:47:09 PDT
Forgive me if this is completely obvious...

Fonts that are common web-fonts (ie: times, verdana, trebuchet ms, tahoma...) and Lucida Grande are suspiciously absent from the Fonts.plist file that is created upon running Safari for Windows. Now, these fonts (including the Lucida Grande font) are and were installed in my windows/fonts folder before Safari was ever installed. This is on 5 different machines (XP to Safari) that I have had either no fonts or garbled text in Safari. Simply adding reference to these fonts in the Fonts.plist file (plus their different styles - bold, italic, bold-italic) has effectively solved the problem for me.

Why does the Fonts.plist file not reference these pre-installed fonts when it is created? Since adding them after the installation seems to fix the problem, is the solution to make sure that they are added upon creation?
Comment 72 Kelly Cunningham 2007-06-17 07:48:55 PDT
(In reply to comment #71)
> was ever installed. This is on 5 different machines (XP to Safari)

Meant to say: XP to Vista
Comment 73 Cameo Wood 2007-06-21 15:10:26 PDT
*** Bug 14290 has been marked as a duplicate of this bug. ***
Comment 74 Robert Blaut 2007-08-30 03:28:27 PDT
Isn't this bug fixed in Safari 3.0.2?
Comment 75 Adam Roben (:aroben) 2008-02-01 07:50:26 PST
(In reply to comment #74)
> Isn't this bug fixed in Safari 3.0.2?

Yes, and since it was never a WebKit bug to begin with, I'm closing it as INVALID.