Bug 140649 - fast/hidpi/image-srcset-change-dynamically-from-js-2x.html is flaky
Summary: fast/hidpi/image-srcset-change-dynamically-from-js-2x.html is flaky
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alexey Proskuryakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-19 16:51 PST by Alexey Proskuryakov
Modified: 2015-01-20 10:26 PST (History)
6 users (show)

See Also:


Attachments
proposed fix (20.67 KB, patch)
2015-01-19 16:58 PST, Alexey Proskuryakov
thorton: review+
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews105 for mac-mavericks-wk2 (1002.91 KB, application/zip)
2015-01-19 17:34 PST, Build Bot
no flags Details
Archive of layout-test-results from ews103 for mac-mavericks (597.53 KB, application/zip)
2015-01-19 19:40 PST, Build Bot
no flags Details
a more complete fix (33.22 KB, patch)
2015-01-19 23:07 PST, Alexey Proskuryakov
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2015-01-19 16:51:34 PST
fast/hidpi/image-srcset-change-dynamically-from-js-2x.html sometimes fails on WK2 bots. It sometimes fails, other times has output showing that it reloaded more than once.

The test uses a pretty complicated helper script that has multiple load event handlers that compete with testRunner.setBackingScaleFactor() completion.
Comment 1 Alexey Proskuryakov 2015-01-19 16:58:32 PST
Created attachment 244941 [details]
proposed fix
Comment 2 Alexey Proskuryakov 2015-01-19 17:18:46 PST
Comment on attachment 244941 [details]
proposed fix

View in context: https://bugs.webkit.org/attachment.cgi?id=244941&action=review

> LayoutTests/ChangeLog:8
> +        Speculative fix, streamline resources/srcset-helper.js and remove races.

I could actually reproduce the flakiness with 

run-webkit-tests fast/hidpi/image-srcset-change-dynamically-from-js-2x.html  --no-retry -2 --repeat 1000 -f
Comment 3 Build Bot 2015-01-19 17:34:11 PST
Comment on attachment 244941 [details]
proposed fix

Attachment 244941 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/4856970032971776

New failing tests:
svg/css/svg-resource-fragment-identifier-img-src.html
fast/dom/HTMLImageElement/sizes/image-sizes-2x.html
Comment 4 Build Bot 2015-01-19 17:34:15 PST
Created attachment 244943 [details]
Archive of layout-test-results from ews105 for mac-mavericks-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews105  Port: mac-mavericks-wk2  Platform: Mac OS X 10.9.5
Comment 5 Build Bot 2015-01-19 19:40:29 PST
Comment on attachment 244941 [details]
proposed fix

Attachment 244941 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6596122952859648

New failing tests:
svg/css/svg-resource-fragment-identifier-img-src.html
fast/dom/HTMLImageElement/sizes/image-sizes-2x.html
Comment 6 Build Bot 2015-01-19 19:40:32 PST
Created attachment 244956 [details]
Archive of layout-test-results from ews103 for mac-mavericks

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews103  Port: mac-mavericks  Platform: Mac OS X 10.9.5
Comment 7 Alexey Proskuryakov 2015-01-19 23:07:00 PST
Created attachment 244970 [details]
a more complete fix

Turns out that:

1. The script was used outside its directory, so more tests needed to be updated.
2. We had two copies of the script, and thus an opportunity to unify them.

I think that this fixes another flaky test, which was wrongfully skipped before.
Comment 8 WebKit Commit Bot 2015-01-20 10:25:58 PST
Comment on attachment 244970 [details]
a more complete fix

Clearing flags on attachment: 244970

Committed r178721: <http://trac.webkit.org/changeset/178721>
Comment 9 WebKit Commit Bot 2015-01-20 10:26:05 PST
All reviewed patches have been landed.  Closing bug.