Bug 140586 - Web Inspector: REGRESSION: CSS Resource appears as empty after editing it via Styles sidebar
Summary: Web Inspector: REGRESSION: CSS Resource appears as empty after editing it via...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Critical
Assignee: jonowells
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2015-01-17 19:31 PST by Nikita Vasilyev
Modified: 2015-02-06 13:33 PST (History)
8 users (show)

See Also:


Attachments
Animated GIF (3.04 MB, image/gif)
2015-01-17 19:31 PST, Nikita Vasilyev
no flags Details
[PATCH] Fix. (5.79 KB, patch)
2015-02-06 12:20 PST, jonowells
no flags Details | Formatted Diff | Diff
[SCREENSHOT] patched behavior 1 (119.09 KB, image/png)
2015-02-06 12:20 PST, jonowells
no flags Details
[SCREENSHOT] patched behavior 2 (84.88 KB, image/png)
2015-02-06 12:21 PST, jonowells
no flags Details
[SCREENSHOT] patched behavior 3 (138.69 KB, image/png)
2015-02-06 12:21 PST, jonowells
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Vasilyev 2015-01-17 19:31:29 PST
Created attachment 244849 [details]
Animated GIF

The bug appeared so far only when inspecting the Inspector. I haven’t yet noticed the problem on any website I’ve tried.

Steps to reproduce (in case you don’t like animated GIFs):
1. Inspect the inspector
2. Turn off any CSS rule by clicking a checkbox
3. Click on the corresponding CSS file link

Expected:
Navigate to the CSS resource with the updated content.

Actual:
CSS resource appears as empty.
Comment 1 Radar WebKit Bug Importer 2015-01-17 19:31:47 PST
<rdar://problem/19510507>
Comment 2 Timothy Hatcher 2015-01-17 19:42:45 PST
I am able to reproduce on daringfireball.net.
Comment 3 Timothy Hatcher 2015-01-17 19:43:58 PST
I wonder if this is caused by making requestContent return a Promise.
Comment 4 Nikita Vasilyev 2015-01-17 19:50:15 PST
Tried it on daringfireball.net. It worked well for a while (https://cloudup.com/cZTqauMCX88), but eventually it broke (https://cloudup.com/cVPAGPUoQCL).
Comment 5 Timothy Hatcher 2015-01-25 08:29:29 PST
Might be a regression for switching to Promises for requestConent?
Comment 6 jonowells 2015-02-06 12:20:20 PST
Created attachment 246171 [details]
[PATCH] Fix.
Comment 7 jonowells 2015-02-06 12:20:48 PST
Created attachment 246172 [details]
[SCREENSHOT] patched behavior 1
Comment 8 jonowells 2015-02-06 12:21:06 PST
Created attachment 246174 [details]
[SCREENSHOT] patched behavior 2
Comment 9 jonowells 2015-02-06 12:21:19 PST
Created attachment 246175 [details]
[SCREENSHOT] patched behavior 3
Comment 10 WebKit Commit Bot 2015-02-06 13:33:33 PST
Comment on attachment 246171 [details]
[PATCH] Fix.

Clearing flags on attachment: 246171

Committed r179755: <http://trac.webkit.org/changeset/179755>
Comment 11 WebKit Commit Bot 2015-02-06 13:33:37 PST
All reviewed patches have been landed.  Closing bug.