Bug 140413 - [GTK] TestWebKitAccessibility fails
Summary: [GTK] TestWebKitAccessibility fails
Status: RESOLVED DUPLICATE of bug 132134
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-13 14:39 PST by Michael Catanzaro
Modified: 2015-01-13 20:07 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Catanzaro 2015-01-13 14:39:57 PST
TestWebKitAccessibility has never worked for me.

If I run the full 'run-gtk-tests' script with all preceeding tests, then it fails with this error:

** (/home/mcatanzaro/WebKit/Tools/gtk/../../WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestWebKitAccessibility:5208): ERROR **: AT-SPI: COuldn't connect to accessibility bus. Is at-spi-bus-launcher running?

So I guess another test is breaking it.

But if I run the test on its own, 'run-gtk-tests WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestWebKitAccessibility', then ii findTestServerApplication(), atspi_accessible_get_child_count() returns 1, and atspi_accessible_get_child_at_index() returns "WebKitBuild/Release/bin/TestWebKitAPI/WebKit2Gtk/TestWebKitAccessibility" without quotes. But the test is expecting "AccessibilityTestServer" to be returned.
Comment 1 Carlos Alberto Lopez Perez 2015-01-13 15:59:34 PST
This may be related to bug 132134.
Comment 2 Michael Catanzaro 2015-01-13 20:07:11 PST
I think we have two different issues, but they are both mentioned in bug #132134. So let's say this is a duplicate for now, and if bug #132134 gets resolved but the test is only half-fixed, then we can reopen this.

*** This bug has been marked as a duplicate of bug 132134 ***