Bug 140289 - [EFL] REGRESSION(r178029): It made compositing tests crash
Summary: [EFL] REGRESSION(r178029): It made compositing tests crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 138551
  Show dependency treegraph
 
Reported: 2015-01-09 03:04 PST by Csaba Osztrogonác
Modified: 2015-01-09 10:58 PST (History)
8 users (show)

See Also:


Attachments
Patch (1.71 KB, patch)
2015-01-09 07:56 PST, Byungseon Shin
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2015-01-09 03:04:45 PST
https://trac.webkit.org/changeset/178029 made compositing tests crash on 
EFL which made the EFL bot early exit and unable to catch any new regression.

Unfortunately the EFL bot was out of order r178020-r178142, but I bisected
manually and confirm that r178029 caused this serious regression.

Crash logs can be found here: (at least for a month, will be deleted automatically)
https://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/18835
Comment 1 Byungseon Shin 2015-01-09 03:37:13 PST
I have found the call stack of crash from your link <https://build.webkit.org/builders/EFL%20Linux%2064-bit%20Release%20WK2/builds/18835
>.


18:59:49.163 21071 worker/3 compositing/backing/no-backing-for-clip-overlap.html crashed, (stderr lines):
18:59:49.163 21071   1   0x7ffb1cebf8c0
18:59:49.163 21071   2   0x7ffb1d080c30
18:59:49.163 21071   3   0x7ffb1ed33c85 WebCore::CoordinatedGraphicsLayer::notifyFlushRequired()
18:59:49.163 21071   4   0x7ffb1ed37b45 WebCore::CoordinatedGraphicsLayer::removeFromParent()
18:59:49.164 21071   5   0x7ffb1ed361b2 WebCore::CoordinatedGraphicsLayer::~CoordinatedGraphicsLayer()
18:59:49.164 21071   6   0x7ffb1ed36791 WebCore::CoordinatedGraphicsLayer::~CoordinatedGraphicsLayer()
18:59:49.164 21071   7   0x7ffb1ead6ecc WebCore::RenderLayerBacking::updateChildClippingStrategy(bool)
18:59:49.164 21071   8   0x7ffb1ead7131 WebCore::RenderLayerBacking::~RenderLayerBacking()
18:59:49.164 21071   9   0x7ffb1ead72a1 WebCore::RenderLayerBacking::~RenderLayerBacking()
18:59:49.164 21071   10  0x7ffb1eacacf2 WebCore::RenderLayer::clearBacking(bool)
18:59:49.164 21071   11  0x7ffb1eacae4d WebCore::RenderLayer::~RenderLayer()
18:59:49.164 21071   12  0x7ffb1eacb0f1 WebCore::RenderLayer::~RenderLayer()
18:59:49.164 21071   13  0x7ffb1eb1095f WebCore::RenderObject::willBeDestroyed()
18:59:49.164 21071   14  0x7ffb1eb133f9 WebCore::RenderObject::destroy()

I can confirm that crash happens when clearing childClippingMaskLayer of CoordinatedGraphics Layer as in the following code.


 1433  void RenderLayerBacking::updateChildClippingStrategy(bool needsDescendentsClippingLayer)
 1434  {
 ................
 1453    } else {
 1454        if (m_childClippingMaskLayer) {
 1455            m_childClippingMaskLayer = nullptr; 

I am investigating the reason why it makes crash on EFL port.
Comment 2 Byungseon Shin 2015-01-09 07:56:51 PST
Created attachment 244342 [details]
Patch
Comment 3 Csaba Osztrogonác 2015-01-09 09:41:20 PST
(In reply to comment #2)
> Created attachment 244342 [details]
> Patch

I checked this patch locally, it fixes the EFL issue for me.
Comment 4 WebKit Commit Bot 2015-01-09 10:58:29 PST
Comment on attachment 244342 [details]
Patch

Clearing flags on attachment: 244342

Committed r178176: <http://trac.webkit.org/changeset/178176>
Comment 5 WebKit Commit Bot 2015-01-09 10:58:33 PST
All reviewed patches have been landed.  Closing bug.