Bug 140273 - Botwatcher's Dashboard is cramped
Summary: Botwatcher's Dashboard is cramped
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dana Burkart
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-08 15:22 PST by Dana Burkart
Modified: 2015-02-04 16:38 PST (History)
2 users (show)

See Also:


Attachments
Add "heading" and "crashesOnly" keys. (15.93 KB, patch)
2015-02-04 15:37 PST, Dana Burkart
ap: review+
ap: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dana Burkart 2015-01-08 15:22:18 PST
On smaller screens, the botwatcher's dashboard is starting to feel cramped. We should make the CSS more responsive to screen resolution so that we can add another column or two. Right now, we can't add any more columns to the dashboard without sacrificing some usability of the dashboard.
Comment 1 Alexey Proskuryakov 2015-01-08 19:13:48 PST
My idea was that we would rename Performance column to Misc, and add more bots there. And for additional styles of testing, we csn just add something to an existing cell alongside a debug/release. 

So, I'm not sure if we will need more columns.
Comment 2 Dana Burkart 2015-02-04 14:59:19 PST
I think I'm going to re-purpose this bug to allow for a couple of new keys:

1) "heading" -- this will allow a builderQueue to have an arbitrary heading (replacing the previous performanceTestHeading key to make it more general). This will allow us to add new builders in columns which already exist.

2) "crashesOnly" -- this isn't related to the 'crampedness' of the dashboard, but will be an enhancement for some tester queues which only care about crashes (GuardMalloc) for example.

I can split out 2 into a separate bug, but I was working on it at the same time as the other one, so this would just be convenient.
Comment 3 Dana Burkart 2015-02-04 15:37:20 PST
Created attachment 246062 [details]
Add "heading" and "crashesOnly" keys.
Comment 4 Alexey Proskuryakov 2015-02-04 15:57:46 PST
Comment on attachment 246062 [details]
Add "heading" and "crashesOnly" keys.

View in context: https://bugs.webkit.org/attachment.cgi?id=246062&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotIteration.js:232
> -            if (!testResults.failureCount && !testResults.flakyCount && !testResults.totalLeakCount && !testResults.uniqueLeakCount && !testResults.newPassesCount && !testResults.missingCount) {
> +            if (!testResults.failureCount && !testResults.flakyCount && !testResults.totalLeakCount && !testResults.uniqueLeakCount && !testResults.newPassesCount && !testResults.missingCount && !testResults.crashCount) {

Not sure if this change is needed - aren't crashes always included in failures?

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotQueueView.js:320
> +    _appendBuild: function(queues, label, appendFunction)

I think that the functions whose names start with an underscore are meant to be public to the class, and this one is called by subclasses. So, I think that the name should be "appendBuild".

Or even "appendBuildStyle" for clarity.

> Tools/BuildSlaveSupport/build.webkit.org-config/public_html/dashboard/Scripts/BuildbotQueueView.js:325
> +            releaseLabel.textContent = queue.heading ? queue.heading : label;

Probably worth renaming the argument to "defaultLabel".
Comment 5 Dana Burkart 2015-02-04 16:38:01 PST
Committed r179650 with Alexey's suggested changes.