Bug 139829 - copy-webkitlibraries-to-product-directory uses wrong SDK when called from build-webkit
Summary: copy-webkitlibraries-to-product-directory uses wrong SDK when called from bui...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac All
: P2 Normal
Assignee: Daniel Bates
URL:
Keywords:
Depends on:
Blocks: 139831
  Show dependency treegraph
 
Reported: 2014-12-19 12:37 PST by Daniel Bates
Modified: 2014-12-19 16:15 PST (History)
4 users (show)

See Also:


Attachments
Patch (5.19 KB, patch)
2014-12-19 12:42 PST, Daniel Bates
no flags Details | Formatted Diff | Diff
Patch (5.86 KB, patch)
2014-12-19 12:48 PST, Daniel Bates
ap: review+
ap: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Bates 2014-12-19 12:37:32 PST
The script build-webkit calls copy-webkitlibraries-to-product-directory using --sdk to specify the Xcode SDK to use, but copy-webkitlibraries-to-product-directory only recognizes --sdk-name. The script copy-webkitlibraries-to-product-directory is the only tool that recognizes --sdk-name instead of --sdk. We should make copy-webkitlibraries-to-product-directory consistent with our other tools, remove --sdk-name, and teach it to recognize --sdk.
Comment 1 Daniel Bates 2014-12-19 12:42:10 PST
Created attachment 243565 [details]
Patch
Comment 2 Daniel Bates 2014-12-19 12:48:48 PST
Created attachment 243567 [details]
Patch
Comment 3 Alexey Proskuryakov 2014-12-19 15:06:09 PST
Comment on attachment 243567 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=243567&action=review

> Tools/Scripts/copy-webkitlibraries-to-product-directory:-76
> -    'sdk-name=s' => \$sdkName,

I think that you should also remove this line above:

my $sdkName = ""; # Ideally we only use this for build commands, rather than deciding policies about what needs to get copied or built and where it needs to be placed.

> Tools/Scripts/copy-webkitlibraries-to-product-directory:103
> +sub ranLib($)

This function name lacks a verb. Maybe executeRanlib? Or if there is a more helpful explanation of what this function does, that should be in the name.
Comment 4 Daniel Bates 2014-12-19 16:03:49 PST
(In reply to comment #3)
> > Tools/Scripts/copy-webkitlibraries-to-product-directory:-76
> > -    'sdk-name=s' => \$sdkName,
> 
> I think that you should also remove this line above:
> 
> my $sdkName = ""; # Ideally we only use this for build commands, rather than
> deciding policies about what needs to get copied or built and where it needs
> to be placed.

Will remove.

> 
> > Tools/Scripts/copy-webkitlibraries-to-product-directory:103
> > +sub ranLib($)
> 
> This function name lacks a verb. Maybe executeRanlib? Or if there is a more
> helpful explanation of what this function does, that should be in the name.

Will rename to updateTableOfContentsForLibrary.
Comment 5 Daniel Bates 2014-12-19 16:09:05 PST
(In reply to comment #4)
> > 
> > > Tools/Scripts/copy-webkitlibraries-to-product-directory:103
> > > +sub ranLib($)
> > 
> > This function name lacks a verb. Maybe executeRanlib? Or if there is a more
> > helpful explanation of what this function does, that should be in the name.
> 
> Will rename to updateTableOfContentsForLibrary.

Actually, there are many references through out this script to ranlib. For now, I'm going to go with your suggestion and rename the function to executeRanlib() for consistency. I suggest we look to update the terminology used in this script in another patch.
Comment 6 Daniel Bates 2014-12-19 16:15:21 PST
Committed r177602: <http://trac.webkit.org/changeset/177602>