Bug 139745 - File Upload Support
Summary: File Upload Support
Status: RESOLVED DUPLICATE of bug 137759
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.10
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-17 13:31 PST by Justin Schneck
Modified: 2014-12-18 11:46 PST (History)
2 users (show)

See Also:


Attachments
Sample Xcode Project displaying the issue (67.69 KB, application/zip)
2014-12-18 10:30 PST, Justin Schneck
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin Schneck 2014-12-17 13:31:50 PST
<input type="file"> does not present an open file panel or expose an API method
Comment 1 Alexey Proskuryakov 2014-12-18 00:21:54 PST
Could you please describe the issue in more detail?
- What OS version, and which WebKit build are you using?
- What are the specific steps to reproduce?
- What API method are you talking about?
Comment 2 Justin Schneck 2014-12-18 10:30:51 PST
Created attachment 243499 [details]
Sample Xcode Project displaying the issue
Comment 3 Justin Schneck 2014-12-18 11:18:20 PST
The problem exists in Mac OS 10.10 when using WKWebView. With WebView there used to be a method - (void)webView:runOpenPanelForFileButtonWithResultListener:. This would allow you to implement an NSOpenPanel to select a file / files and then return to the result listener the filename for submission. I have attached a sample project which uses the WKWebView available in Mac OS 10.10. This project renders a input element and displays the choose file button, but you can see there is nothing to handle it. It seems this logic was added to the WebKit2 API for iOS but not for Mac OS.

Let me know if there is any additional information you require.
Comment 4 Alexey Proskuryakov 2014-12-18 11:44:43 PST
Thank you for the clarification!

Anders told me that this is a known issue, but I couldn't find an older bug in Bugzilla.
Comment 5 Alexey Proskuryakov 2014-12-18 11:46:47 PST
There it is, bug 137759.

*** This bug has been marked as a duplicate of bug 137759 ***