Currently PageThrottler constructs the PageActivityState, holds a copy of the ViewState,
and an optional UserActivity.
Instead, still construct the PageActivityState but just pass this out via the Page to WebPage.
Logic From PageThrottler::updateUserActivity merged into WebPage::updateUserActivity.
Created attachment 243393 [details]
Comment on attachment 243393 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=243393&action=review
> + void setPageActivityState(PageActivityState::Flags);
Seems like this should just be named "setActivityState" and "ActivityState".
PageThrottler needs a new name too (since it no longer throttles!), will rename in a follow up.
Transmitting file data ............
Committed revision 177396.