Bug 139541 - Web Inspector: lines highlighted during debugger stepping should not animate together
Summary: Web Inspector: lines highlighted during debugger stepping should not animate ...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 141415 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-11 09:32 PST by Brian Burg
Modified: 2016-12-24 23:24 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brian Burg 2014-12-11 09:32:24 PST
Steps to reproduce:

1. Pause the debugger
2. Hit "step over" several times quickly.

It seems that when later lines are highlighted, the animation/transition is restarted for prior highlights. So if you step through code quickly, many lines will flash at once.
Comment 1 Radar WebKit Bug Importer 2014-12-17 11:25:26 PST
<rdar://problem/19281604>
Comment 2 Timothy Hatcher 2015-03-19 09:19:53 PDT
*** Bug 141415 has been marked as a duplicate of this bug. ***
Comment 3 Timothy Hatcher 2015-03-19 09:20:32 PDT
See bug 141415 for an animated GIF.
Comment 4 Timothy Hatcher 2015-03-19 09:20:57 PDT
This affects jumping to records in the timelines too.
Comment 5 Brian Burg 2016-12-24 23:24:12 PST
Highlight animation has been removed.