Bug 139471 - [GStreamer] SourceBufferPrivateGstreamer should emit 'updateend'
Summary: [GStreamer] SourceBufferPrivateGstreamer should emit 'updateend'
Status: RESOLVED DUPLICATE of bug 139441
Alias: None
Product: WebKit
Classification: Unclassified
Component: Media Elements (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-09 23:42 PST by Bartlomiej Gajda
Modified: 2014-12-10 03:46 PST (History)
2 users (show)

See Also:


Attachments
call appendComplete so it will emit updateend per spec (3.69 KB, patch)
2014-12-09 23:47 PST, Bartlomiej Gajda
pnormand: review-
pnormand: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bartlomiej Gajda 2014-12-09 23:42:29 PST
Currently it does not.

While of course this is not ready for complete specification (mostly due to buffered missing), 
enabling this would allow testing for other independent issues.

//btw:

What should be proper way to tag such issues? both [GStreamer] and [MSE] ? 
I don't want people unrelated to platform specific issues to be on auto CC, but it would separate MSE specific issues from general media player related etc.
Comment 1 Bartlomiej Gajda 2014-12-09 23:47:39 PST
Created attachment 242990 [details]
call appendComplete so it will emit updateend per spec

Initial version of this.

Check for 'updateend' is part of other tests, but we won't pass them completely, so shall I add new one which tests only this? Or edit something? Or no test is needed since this is yet unstable and/or unsupported port feature?
Comment 2 Sebastian Dröge (slomo) 2014-12-10 00:41:21 PST
That's fixed already in my patch in bug #139441, which also solves many other problems. I'm currently changing quite a bit on top of that to make even more tests pass.
Comment 3 Philippe Normand 2014-12-10 03:44:36 PST

*** This bug has been marked as a duplicate of bug 139441 ***