Bug 139379 - Fix the parsing of advanced :lang() after r176902
Summary: Fix the parsing of advanced :lang() after r176902
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Benjamin Poulain
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-07 17:51 PST by Benjamin Poulain
Modified: 2014-12-08 15:54 PST (History)
4 users (show)

See Also:


Attachments
Patch (23.05 KB, patch)
2014-12-07 20:19 PST, Benjamin Poulain
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2014-12-07 17:51:44 PST
Fix the parsing of advanced :lang() after r176902
Comment 1 Benjamin Poulain 2014-12-07 20:19:39 PST
Created attachment 242782 [details]
Patch
Comment 2 Mark Lam 2014-12-07 22:59:13 PST
Comment on attachment 242782 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=242782&action=review

> Source/WebCore/css/CSSParser.cpp:11489
> +        }

If you want this ‘}’, then you should move the one at line 11503 before the #endif.
Comment 3 Benjamin Poulain 2014-12-08 00:22:02 PST
Comment on attachment 242782 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=242782&action=review

>> Source/WebCore/css/CSSParser.cpp:11489
>> +        }
> 
> If you want this ‘}’, then you should move the one at line 11503 before the #endif.

Oh crap, my bad. I'll fix that before landing.
Comment 4 Andreas Kling 2014-12-08 14:53:29 PST
Comment on attachment 242782 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=242782&action=review

r=me

> Source/WebCore/ChangeLog:18
> +        The problem is that CSSParserString does not keep the source string alive.
> +        Consequently, the list of language range was accumulating pointers to dead
> +        StringImpls.

Whoops!
Comment 5 Benjamin Poulain 2014-12-08 15:54:27 PST
Committed r176983: <http://trac.webkit.org/changeset/176983>