Bug 13934 - REGRESSION: http/tests/navigation/relativeanchor-goback is failing
Summary: REGRESSION: http/tests/navigation/relativeanchor-goback is failing
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Beth Dakin
URL: http://build.webkit.org/results/post-...
Keywords: InRadar, LayoutTestFailure, Regression
Depends on:
Blocks:
 
Reported: 2007-05-30 11:01 PDT by Adam Roben (:aroben)
Modified: 2007-06-08 13:15 PDT (History)
1 user (show)

See Also:


Attachments
Patch (2.75 KB, patch)
2007-06-08 13:10 PDT, Beth Dakin
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2007-05-30 11:01:15 PDT
http/tests/navigation/relativeanchor-goback is failing on the buildbot.
Comment 1 Adam Roben (:aroben) 2007-05-30 11:02:24 PDT
<rdar://problem/5237081>
Comment 2 Beth Dakin 2007-06-07 16:45:45 PDT
Darin mentioned that he thought that this was due to Adele's change to form element saving.
Comment 3 Beth Dakin 2007-06-07 20:14:22 PDT
This was, indeed, caused by http://trac.webkit.org/projects/webkit/changeset/21738
Comment 4 Beth Dakin 2007-06-07 21:14:21 PDT
The failing test seems straighforward enough once I read it, but I keep thinking that I understand it, and then I cannot reproduce it inside the browser. (The test relies heavily on dump render tree.)
Comment 5 Beth Dakin 2007-06-08 10:42:41 PDT
I might understand what is going on here, but I haven't confirmed yet. I think that these new results may actually be correct. The reason that I have been having so much trouble reproducing the in browser, is that the browser has a back-forward cache, and DumpRenderTree turns the back-forward cache off. So When this test "goes back" it actually kicks off a new load. And when we kick off a new load in the browser, we do not expect the form input to be retained. I think that this test was exposing the very bug that Adele fixed. Probably once upon a time, it worked as expected because there was a time when the back-forward list was enabled for DumpRenderTree. But now that it is disabled, I actually think that it is correct that the form values are reset to their defaults.

I am going to work on confirming this.
Comment 6 Beth Dakin 2007-06-08 11:04:39 PDT
I have confirmed that re-enabling the back-forward cache for DumpRenderTree causes the test to pass. 

As I said in my previous comment, I think that this test should only pass with the back-forward cache enabled. I think that it *was* passing in DumpRenderTree before because it was hitting that case that Adele fixed. I am going to do a bit more investigation.
Comment 7 Beth Dakin 2007-06-08 12:34:04 PDT
Okay, I looked at the in the Debugger, and I feel confident that my assessment is correct. The relative URL should be treated as a different URL when it is loaded rather than "gone back to" via the back button. We have always treated them as separate if you re-enter the URL in the address bar, so it seems the same should hold for DumpRenderTree. I will edit the test to be less confusing and update the expected results. 
Comment 8 Beth Dakin 2007-06-08 13:10:24 PDT
Created attachment 14905 [details]
Patch

Here is a patch that uploads new results for the test. I did not end up changing the text in the js-file to make the results more clear because it affects to many other tests. Seems like something that should be done after a fuller investigation of all of the tests that use that js file.
Comment 9 Brady Eidson 2007-06-08 13:11:42 PDT
Comment on attachment 14905 [details]
Patch

Yay!
Comment 10 Beth Dakin 2007-06-08 13:15:09 PDT
Fixed with r22076.