Bug 139220 - [GTK] JHBuild module gst-plugins-bad fails to build if the GNUStep libraries are installed.
Summary: [GTK] JHBuild module gst-plugins-bad fails to build if the GNUStep libraries ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Carlos Alberto Lopez Perez
URL: https://bugzilla.gnome.org/show_bug.c...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-03 02:41 PST by Carlos Alberto Lopez Perez
Modified: 2014-12-03 04:20 PST (History)
4 users (show)

See Also:


Attachments
Patch (11.34 KB, patch)
2014-12-03 02:46 PST, Carlos Alberto Lopez Perez
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2014-12-03 02:41:43 PST
The jhbuild module gst-plugins-bad fails to build on a GNU/Linux system if the GNUStep libraries are installed on the system.

This has been reported here: https://bugzilla.gnome.org/show_bug.cgi?id=739152 and upstream "fixed" by removing support for GNUStep.

So, to avoid breaking the build on machines that have the GNUStep libraries installed this patch should be added to our jhbuild.
Comment 1 Carlos Alberto Lopez Perez 2014-12-03 02:46:45 PST
Created attachment 242483 [details]
Patch
Comment 2 Philippe Normand 2014-12-03 02:52:14 PST
Comment on attachment 242483 [details]
Patch

Let's wait EWS green light before setting cq+
Comment 3 Carlos Alberto Lopez Perez 2014-12-03 03:41:08 PST
Comment on attachment 242483 [details]
Patch

GTK EWS is green :)
Comment 4 WebKit Commit Bot 2014-12-03 04:20:33 PST
Comment on attachment 242483 [details]
Patch

Clearing flags on attachment: 242483

Committed r176717: <http://trac.webkit.org/changeset/176717>
Comment 5 WebKit Commit Bot 2014-12-03 04:20:37 PST
All reviewed patches have been landed.  Closing bug.