Bug 139050 - [Gtk] ASSERTION FAILED: !m_dirty in WebCore::GraphicsLayerTransform::combined
Summary: [Gtk] ASSERTION FAILED: !m_dirty in WebCore::GraphicsLayerTransform::combined
Status: RESOLVED DUPLICATE of bug 151039
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 116980
  Show dependency treegraph
 
Reported: 2014-11-25 10:57 PST by Renata Hodovan
Modified: 2017-12-15 04:42 PST (History)
4 users (show)

See Also:


Attachments
Test case (164 bytes, text/html)
2014-11-25 10:57 PST, Renata Hodovan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Renata Hodovan 2014-11-25 10:57:17 PST
Created attachment 242203 [details]
Test case

Load the following test with debug WebKit:

<!DOCTYPE html>
<style>
* {
    outline:inherit
}

*  {
    overflow:scroll;
    width:0;
    opacity:0.1;
}
</style>
<video>
    <source src="a"></source>
</video>


Note: the 2 rulesets cannot be combined.


Backtrace:

ASSERTION FAILED: !m_dirty
../../Source/WebCore/platform/graphics/GraphicsLayerTransform.cpp(83) : WebCore::TransformationMatrix WebCore::GraphicsLayerTransform::combined()

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fff98c4e700 (LWP 22688)]
0x00007fffedc7ea89 in WTFCrash () at ../../Source/WTF/wtf/Assertions.cpp:321
321	    *(int *)(uintptr_t)0xbbadbeef = 0;
#0  0x00007fffedc7ea89 in WTFCrash () at ../../Source/WTF/wtf/Assertions.cpp:321
#1  0x00007ffff38800a0 in WebCore::GraphicsLayerTransform::combined (this=0xc32f20) at ../../Source/WebCore/platform/graphics/GraphicsLayerTransform.cpp:83
#2  0x00007ffff38cce2c in WebCore::TextureMapperLayer::computeOverlapRegions (this=0xc32ee0, overlapRegion=..., nonOverlapRegion=..., mode=WebCore::TextureMapperLayer::ResolveSelfOverlapIfNeeded) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:280
#3  0x00007ffff38cd027 in WebCore::TextureMapperLayer::computeOverlapRegions (this=0xc31640, overlapRegion=..., nonOverlapRegion=..., mode=WebCore::TextureMapperLayer::ResolveSelfOverlapIfNeeded) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:295
#4  0x00007ffff38cd027 in WebCore::TextureMapperLayer::computeOverlapRegions (this=0xc31eb0, overlapRegion=..., nonOverlapRegion=..., mode=WebCore::TextureMapperLayer::ResolveSelfOverlapAlways) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:295
#5  0x00007ffff38cd3ea in WebCore::TextureMapperLayer::paintUsingOverlapRegions (this=0xc31eb0, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:317
#6  0x00007ffff38ce552 in WebCore::TextureMapperLayer::paintRecursive (this=0xc31eb0, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:440
#7  0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0xc32720, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#8  0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0xc32720, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#9  0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0xc32720, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#10 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x7dd7a0, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#11 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x7dd7a0, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#12 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x7dd7a0, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#13 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x8e4190, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#14 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x8e4190, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#15 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x8e4190, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#16 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x8e3c90, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#17 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x8e3c90, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#18 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x8e3c90, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#19 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x8e3790, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#20 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x8e3790, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#21 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x8e3790, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#22 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x6ec860, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#23 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x6ec860, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#24 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x6ec860, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#25 0x00007ffff38cc4d5 in WebCore::TextureMapperLayer::paintSelfAndChildren (this=0x6ec360, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:182
#26 0x00007ffff38cc80a in WebCore::TextureMapperLayer::paintSelfAndChildrenWithReplica (this=0x6ec360, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:222
#27 0x00007ffff38ce532 in WebCore::TextureMapperLayer::paintRecursive (this=0x6ec360, options=...) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:436
#28 0x00007ffff38cb8ae in WebCore::TextureMapperLayer::paint (this=0x6ec360) at ../../Source/WebCore/platform/graphics/texmap/TextureMapperLayer.cpp:83
#29 0x00007ffff2bacd12 in WebKit::LayerTreeHostGtk::compositeLayersToContext (this=0x7ddca0, purpose=WebKit::LayerTreeHostGtk::NotForResize) at ../../Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:296
#30 0x00007ffff2bace41 in WebKit::LayerTreeHostGtk::flushAndRenderLayers (this=0x7ddca0) at ../../Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:321
#31 0x00007ffff2bac889 in WebKit::LayerTreeHostGtk::layerFlushTimerFired (this=0x7ddca0) at ../../Source/WebKit2/WebProcess/WebPage/gtk/LayerTreeHostGtk.cpp:256
#32 0x00007ffff2bb0133 in std::_Mem_fn<void (WebKit::LayerTreeHostGtk::*)()>::operator()<, void>(WebKit::LayerTreeHostGtk*) const (this=0x6ca8e0, __object=0x7ddca0) at /usr/include/c++/4.8/functional:601
#33 0x00007ffff2bafc56 in std::_Bind<std::_Mem_fn<void (WebKit::LayerTreeHostGtk::*)()> (WebKit::LayerTreeHostGtk*)>::__call<void, , 0ul>(std::tuple<>&&, std::_Index_tuple<0ul>) (this=0x6ca8e0, __args=<unknown type in /home/reni/data/REPOS/webkit/WebKitBuild/Debug/lib/libwebkit2gtk-4.0.so.37, CU 0x6a483db, DIE 0x6abae94>) at /usr/include/c++/4.8/functional:1296
#34 0x00007ffff2baf556 in std::_Bind<std::_Mem_fn<void (WebKit::LayerTreeHostGtk::*)()> (WebKit::LayerTreeHostGtk*)>::operator()<, void>() (this=0x6ca8e0) at /usr/include/c++/4.8/functional:1355
#35 0x00007ffff2baef43 in std::_Function_handler<void (), std::_Bind<std::_Mem_fn<void (WebKit::LayerTreeHostGtk::*)()> (WebKit::LayerTreeHostGtk*)> >::_M_invoke(std::_Any_data const&) (__functor=...) at /usr/include/c++/4.8/functional:2071
#36 0x00007ffff279f32a in std::function<void ()>::operator()() const (this=0x7fffffffd5c8) at /usr/include/c++/4.8/functional:2464
#37 0x00007fffedcc82f6 in WTF::GMainLoopSource::voidCallback (this=0x7ddd28) at ../../Source/WTF/wtf/gobject/GMainLoopSource.cpp:365
#38 0x00007fffedcc8a67 in WTF::GMainLoopSource::voidSourceCallback (source=0x7ddd28) at ../../Source/WTF/wtf/gobject/GMainLoopSource.cpp:456
#39 0x00007fffeaafea2d in g_main_dispatch (context=0x478020) at gmain.c:3064
#40 g_main_context_dispatch (context=context@entry=0x478020) at gmain.c:3663
#41 0x00007fffeaafed98 in g_main_context_iterate (context=0x478020, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3734
#42 0x00007fffeaaff05a in g_main_loop_run (loop=0x901590) at gmain.c:3928
#43 0x00007ffff464b42e in WTF::RunLoop::run () at ../../Source/WTF/wtf/gtk/RunLoopGtk.cpp:59
#44 0x00007ffff2bb8250 in WebKit::ChildProcessMain<WebKit::WebProcess, WebKit::WebProcessMain> (argc=2, argv=0x7fffffffd968) at ../../Source/WebKit2/Shared/unix/ChildProcessMain.h:61
#45 0x00007ffff2bb80b5 in WebKit::WebProcessMainUnix (argc=2, argv=0x7fffffffd968) at ../../Source/WebKit2/WebProcess/gtk/WebProcessMainGtk.cpp:73
#46 0x0000000000400891 in main (argc=2, argv=0x7fffffffd968) at ../../Source/WebKit2/WebProcess/EntryPoint/unix/WebProcessMain.cpp:44
Comment 1 Michael Catanzaro 2017-12-15 04:42:35 PST

*** This bug has been marked as a duplicate of bug 151039 ***