Bug 13891 - REGRESSION: Taloussanomat.fi web site not rendering correctly
Summary: REGRESSION: Taloussanomat.fi web site not rendering correctly
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.taloussanomat.fi
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-05-27 00:14 PDT by Marko Buuri
Modified: 2008-02-05 07:58 PST (History)
3 users (show)

See Also:


Attachments
Reduction (310 bytes, text/html)
2007-05-27 13:01 PDT, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Buuri 2007-05-27 00:14:35 PDT
Taloussanomat.fi web site not rendering correctly with webkit nighly versions. This is regression from Safari 2.0.4 (419.3) that renders the site perfectly.
Comment 1 Alexey Proskuryakov 2007-05-27 00:28:50 PDT
Confirmed with r21802. Interestingly, the content seems to be rendered correctly at first, but then gets moved out of sight.
Comment 2 mitz 2007-05-27 03:10:47 PDT
I'm seeing the same behavior with both Safari 2.0.4 and TOT, namely that the main content seems to be pushed down below the leftmost column (presumably because their container gets an unexpected vertical scrollbar).
Comment 3 Marko Buuri 2007-05-27 08:05:24 PDT
(In reply to comment #2)
> I'm seeing the same behavior with both Safari 2.0.4 and TOT, namely that the
> main content seems to be pushed down below the leftmost column (presumably
> because their container gets an unexpected vertical scrollbar).
>

Very interesting, because I am not able to reproduce this problem with this standard setup: iMac G5, OS X 10.4.9, Safari 2.0.4. The nightlies on the other hand have been rendering this site incorrectly for as long I have have used them on this same system, which is for as long as roughly few weeks. 
Comment 4 Dave Hyatt 2007-05-27 12:14:28 PDT
The site uses overflow-x and overflow-y, which were not supported by Safari 2.  Now we are honoring them.   For some reason we're overflow vertically when Firefox did not, so we'll need to reduce to figure out why.
Comment 5 mitz 2007-05-27 13:01:27 PDT
Created attachment 14749 [details]
Reduction

I think this is about font-size: 0 mapping to 1px (if that's still the case).
Comment 6 mitz 2007-05-27 13:03:10 PDT
I'm pretty sure it's the font-size: 0 thing.
Comment 7 Dave Hyatt 2007-05-27 14:51:42 PDT
I'm not sure it's that simple.  Setting a minimum font size of 9px in Firefox does not result in any overflow appearing.
Comment 8 Dave Hyatt 2007-05-27 14:57:45 PDT
Actually never mind.  Firefox seems to special-case 0.  If a font is size 0 then the minimum font size (and zoom) do not apply, since obviously it was not intended to be displayed (makes sense).

The annoyance here of course is that AppKit can't handle zero size fonts, opting to return a font of size 12 instead.
Comment 9 Adele Peterson 2007-08-30 14:47:37 PDT
<rdar://problem/5451500>

Does the problem still occur on the live site?  I'm not sure I see anything wrong in TOT
Comment 10 mitz 2007-08-30 15:08:46 PDT
(In reply to comment #9)
> <rdar://problem/5451500>
> 
> Does the problem still occur on the live site?  I'm not sure I see anything
> wrong in TOT

Looks like usage of overflow-x has been commented-out in <http://www.taloussanomat.fi/css/layout.css>, which fixes the problem on the site.
Comment 11 Robert Blaut 2008-02-05 03:38:13 PST
IMO bug 11004 is related to this bug.