Bug 13813 - REGRESSION (r19136-r19186): Banner is about 10x too big on schwab.com
Summary: REGRESSION (r19136-r19186): Banner is about 10x too big on schwab.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Nobody
URL: http://investing.schwab.com/trading/c...
Keywords: InRadar, NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-05-22 09:30 PDT by Jim Oase
Modified: 2007-08-29 21:14 PDT (History)
6 users (show)

See Also:


Attachments
Screen shot (.jpg) of what I see when accessing my Schwab account. (77.38 KB, image/jpeg)
2007-05-22 09:34 PDT, Jim Oase
no flags Details
Same screen on standard Safari (272.02 KB, image/jpeg)
2007-05-22 17:30 PDT, Jim Oase
no flags Details
Source of Offending page. (111.47 KB, application/pdf)
2007-05-23 05:34 PDT, Jim Oase
no flags Details
HTML source file Offending Page (10.37 KB, text/html)
2007-05-23 08:19 PDT, Jim Oase
no flags Details
Frame Page source (114.98 KB, text/html)
2007-05-23 10:55 PDT, Jim Oase
no flags Details
Big Tabs with the lastest build...... (233.87 KB, application/x-webarchive)
2007-05-25 12:19 PDT, Jim Oase
no flags Details
Big Banner...... still there (233.80 KB, application/x-webarchive)
2007-07-14 06:33 PDT, Jim Oase
no flags Details
Big banner still there...... (10.37 KB, text/html)
2007-08-08 20:18 PDT, Jim Oase
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Oase 2007-05-22 09:30:21 PDT
I am not sure if you can access this page because its my Schwab account opening page.  Here is what I see.  There is a banner at the top of the page that starting a few days ago has been rendering far too big with each nightly build since.  If I knew how to attach a picture I would.

I have not found this characteristic on any other site.

I would like to be more informative.  Unfortunately this is all I know at this time.

Jim
Comment 1 Jim Oase 2007-05-22 09:34:31 PDT
Created attachment 14656 [details]
Screen shot (.jpg)  of what I see when accessing my Schwab account.
Comment 2 David Kilzer (:ddkilzer) 2007-05-22 09:46:30 PDT
Thanks, Jim!  Could you attach a normal-size screenshot of the same part of the screen (using shipping Safari)?

Comment 3 Jim Oase 2007-05-22 17:30:30 PDT
Created attachment 14670 [details]
Same screen on standard Safari
Comment 4 David Kilzer (:ddkilzer) 2007-05-22 22:42:56 PDT
Thanks Jim!  In order to fix this issue, we really need HTML (and CSS) source for the page in question.

If possible, saving a .webarchive of the page (from a Nightly WebKit) would be a good option, as would saving the page from Firefox in "web page, complete" format and attaching a zip archive of the files and directories it creates.

If you're concerned about privacy, the best thing to do would be to create a corresponding bug using https://bugreport.apple.com/ and attach the file there.  If you don't have an Apple Developer Connection (ADC) account, you may create a free "online" account on using https://connect.apple.com/.  If you do that, please report the "radar bug number" back here.

Comment 5 David Kilzer (:ddkilzer) 2007-05-22 22:43:55 PDT
(In reply to comment #4)
> [...] as would saving the page from Firefox in "web page, complete"
> format and attaching a zip archive of the files and directories it creates.

If you use this option, please make sure the bug still occurs in a WebKit nightly after it's been saved.  Thanks!

Comment 6 Jim Oase 2007-05-23 05:34:51 PDT
Created attachment 14680 [details]
Source of Offending page.

This banner problem is present on every page using that banner.
Comment 7 David Kilzer (:ddkilzer) 2007-05-23 06:44:05 PDT
(In reply to comment #6)
> Created an attachment (id=14680) [edit]
> Source of Offending page.
> This banner problem is present on every page using that banner.

So is there a particular reason you printed the HTML source to a PDF file instead of attaching the source directly?

I'm afraid that some of the HTML is cut off and missing (on very long lines) and I can't find where the "At a Glance", "Account", "Trade", etc. constructs are located (since they should be text within the source--perhaps they were cut off?).

Please use one of the formats from Comment #4, or alternatively use "File"->"Save As..." from Safari, and select "Page Source" instead of "Web Archive".  Thanks!

Comment 8 Jim Oase 2007-05-23 08:19:44 PDT
Created attachment 14685 [details]
HTML source file Offending Page

Sorry about the file.  I had made it before your email.

Technology has passed me.  Bare with me I will catch up, albeit slowly.   

There were three of us that did the display system for Apollo 13.  I designed the judges stations for the 1972 Olympics and few more projects before retiring in 1999.  I also worked on the display systems for the moon walk.

Jim
Comment 9 David Kilzer (:ddkilzer) 2007-05-23 10:29:08 PDT
(In reply to comment #8)
> Created an attachment (id=14685) [edit]
> HTML source file Offending Page
>
> Sorry about the file.  I had made it before your email.

It's not a problem!  I could have been much clearer when asking for the HTML source code.

Unfortunately, I need you to do one more thing.  You did save the source of the page correctly, but after opening it, I realized it uses <iframe> elements (tags) to load sub-pages into the main page.  The navigation tabs that are too big are in one of those, so we need the the source for that <iframe>.  Here's how:

1. Open the page in your nightly WebKit build.
2. While holding the Ctrl key, press the left mouse button while the mouse pointer is over one of the huge tabs.  (Note that if your Mac has a one-button mouse, just click the one button.)  (If you have a two- or three-button mouse, this is the equivalent of a right-mouse-click.)
3. You should see a menu that includes "Save Frame As..." item.  If not, stop here and report back.
4. Select "Save Frame As...", then save the file in "Page Source" format again, and attach it to this bug.

> Technology has passed me.  Bare with me I will catch up, albeit slowly.   

It hasn't passed you by, you're still using it!  :)  The basics haven't changed in decades--the hardware has just gotten a little faster and the software has gotten bloated.

> There were three of us that did the display system for Apollo 13.  I designed
> the judges stations for the 1972 Olympics and few more projects before retiring
> in 1999.  I also worked on the display systems for the moon walk.

Wow.  I bet you have quite a few stories to tell!  Have you met Lovell, Swigert and Haise?  Were you able to attend the 1972 Olympics?

Comment 10 David Kilzer (:ddkilzer) 2007-05-23 10:30:47 PDT
(In reply to comment #9)
> It hasn't passed you by, you're still using it!  :)  The basics haven't changed
> in decades--the hardware has just gotten a little faster and the software has
> gotten bloated.

Except Safari, WebKit and OS X, of course.  ;)

Comment 11 Jim Oase 2007-05-23 10:55:23 PDT
Created attachment 14691 [details]
Frame Page source

I never met Jim Lovell.  Came close he was a neighbor for awhile of a good friend of mine.

I designed a 7 processor, Z80, CP/M system using multiple, 64K, pages of memory in 1977.  We had it done when I met Dr Gary Kindahl (I hope I spelled his name correct).  The guy Gates lifted DOS from.  We used a register scheme to pass information and control operation much like, I think, Gates did with Windows.

A friend gave me a photo album of some of the projects I worked on.  Suddenly I realized that I had forgot many of those projects.  Take pictures..... you won't regret it.  My album is one of my treasures today.

Jim
Comment 12 David Kilzer (:ddkilzer) 2007-05-25 11:02:08 PDT
(In reply to comment #11)
> Created an attachment (id=14691) [edit]
> Frame Page source

When I open http://bugs.webkit.org/attachment.cgi?id=14691 in my WebKit nightly build, I don't see the huge tabs.  Do you see them, Jim?  If so, try saving a .webarchive of this page (using the steps below as a guideline) and attaching it to this bug.

If not, we're going to need another attachment.  (I apologize, but without a Schwab account, it's not possible to reproduce.)  This is probably the best option:

1. Launch WebKit nightly.
2. Go to a page with big tabs.
3. Select "Save As.." from the "File" menu.
3. Change the "Format" pop-up to "Web Archive".
4. Save the file.

To make sure that we've captured the large tabs:

1. Log out of Schwab.
2. Quit the WebKit nightly.
3. Launch the WebKit nightly.
4. Open the .webarchive file saved above.

The huge tabs should still appear.  If they don't, post a comment here since we need another strategy.

If the huge tabs DO appear, please post the webarchive file.

You might also grab another nightly to make sure the huge tabs haven't mysteriously fixed themselves as well!  http://nightly.webkit.org/

> I designed a 7 processor, Z80, CP/M system using multiple, 64K, pages of memory
> in 1977.  We had it done when I met Dr Gary Kindahl (I hope I spelled his name
> correct).  The guy Gates lifted DOS from.  We used a register scheme to pass
> information and control operation much like, I think, Gates did with Windows.

Wow!  That system was definitely way ahead of it's time!
Comment 13 Jim Oase 2007-05-25 12:19:04 PDT
Created attachment 14729 [details]
Big Tabs with the lastest build......

Good After Noon,

I made the archieve file, close Webkit, restarted WebKit, opened Charls....webarchieve.   The tabs are still big.

I am updating the local newspaper's mac systems.  They still have a Classic printing labels.  Its worn out a couple of printers in its fault free life.

Off course no good deed goes unpunished so as soon as I got the files off an emac it died.  Unfortunately the operator saved all the files to her extremely cluttered desk top and I can't find those damn files yet!!!  ARGH!!  Because she operated in System 9 mostly.  

Right now I am rebuilding her hard drive in hope that even a blind squirrel will find an acorn.  I will beable boot from that drive again in System 9 to get those files into a folder and off the system to their new iMac.

Jim
Comment 14 David Kilzer (:ddkilzer) 2007-05-27 10:16:02 PDT
(In reply to comment #13)
> Created an attachment (id=14729) [edit]
> Big Tabs with the lastest build......

Confirmed!!  Loading the webarchive, I do see the big tabs now using a local debug build of WebKit r21742 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).  Using just shipping Safari, the tabs are normal-sized, so this is a regression.

> Right now I am rebuilding her hard drive in hope that even a blind squirrel
> will find an acorn.  I will beable boot from that drive again in System 9 to
> get those files into a folder and off the system to their new iMac.

Good luck!  (Was there a question in there?  You won't be able to boot System 9 on a new iMac since System 9 doesn't know about the hardware, and System 9 is a PowerPC binary while the new iMac has an Intel chip.  Also, the "Classic" emulation environment doesn't ship with Intel Macs anymore.)

Comment 15 mitz 2007-05-27 11:56:05 PDT
(Most recently?) regressed in <http://trac.webkit.org/projects/webkit/changeset/19164>.
Comment 16 mitz 2007-05-27 23:08:10 PDT
The style declaration says "font-size:12.77 em;", which shipping Safari interprets as 12.77px (since the document is in quirks mode). Starting with r19164, this is interpreted as 12.77em. Firefox 3 just treats the value as invalid (which is what WebKit did just prior to r19164 if I understood correctly).
Comment 17 Dave Hyatt 2007-05-27 23:19:06 PDT
Will have to evangelize the site I guess.
Comment 18 David Kilzer (:ddkilzer) 2007-05-27 23:48:42 PDT
(In reply to comment #17)
> Will have to evangelize the site I guess.

Copying Mark Malone.

Comment 19 Mark Rowe (bdash) 2007-06-13 21:43:44 PDT
This is already in Radar as <rdar://problem/5213266>.
Comment 20 Craig Stein 2007-06-14 16:17:32 PDT
If you change the User Agent under Debug to anything other than Safari 2.0.4, the pages at https://investing.schwab.com/ all render properly.
Comment 21 Oliver Hunt 2007-07-14 00:14:23 PDT
This no longer appears reproducible -- maybe schwab.com fixed the site?
Comment 22 Matt Lilek 2007-07-14 00:31:48 PDT
It looks like at least the windows port has a custom ua workaround for this - http://trac.webkit.org/projects/webkit/browser/trunk/WebKit/win/WebView.cpp#L1559
Comment 23 Jim Oase 2007-07-14 06:33:42 PDT
Created attachment 15514 [details]
Big Banner...... still there

So far the big banner has continued to be there with every build.  Schwab says its because of the BETA stuff.  However selecting User Agent Safari 2.0.4 does not correct the problem.

Jim
Comment 24 David Kilzer (:ddkilzer) 2007-07-14 10:26:30 PDT
Reopening since the bug is still present.  Thanks for retesting Jim!

Changing to P2 to get it off the P1 bug list.

(In reply to comment #23) 
> So far the big banner has continued to be there with every build.  Schwab says
> its because of the BETA stuff.  However selecting User Agent Safari 2.0.4 does
> not correct the problem.

That means that they don't understand the issue then.
Comment 25 David Kilzer (:ddkilzer) 2007-07-14 16:50:15 PDT
(In reply to comment #24)
> Changing to P2 to get it off the P1 bug list.

No, this really should be P1.

> That means that they don't understand the issue then.

The only thing that needs to change is to replace "font-size:12.77 em;" with "font-size:12.77px;" in the CSS.

Comment 26 Jim Oase 2007-08-08 20:18:06 PDT
Created attachment 15876 [details]
Big banner still there......

This problems exist with both Webkit and Safari 3 BETA
Comment 27 David Kilzer (:ddkilzer) 2007-08-08 21:38:29 PDT
(In reply to comment #26)
> Created an attachment (id=15876) [edit]
> Big banner still there......
> 
> This problems exist with both Webkit and Safari 3 BETA

Yep.  I would suggest filing a complaint with Schwab's customer/technical support at this point.

http://www.aboutschwab.com/about/contact/index.html

http://www.schwab.com/public/schwab/nn/customer_service/contact.html?cmsid=P-1005975&lvl1=nn&lvl2=customer_service&refid=P-978988&refpid=P-1021813

Comment 28 David Kilzer (:ddkilzer) 2007-08-24 16:44:45 PDT
(In reply to comment #23)
> So far the big banner has continued to be there with every build.  Schwab says
> its because of the BETA stuff.  However selecting User Agent Safari 2.0.4 does
> not correct the problem.

Apparently they will not fix the issue until Safari 3 is out of beta.  It even mentions "(non-beta)" on this page:

http://www.schwab.com/public/schwab/nn/customer_service/browsers.html?cmsid=P-1414946&lvl1=nn&lvl2=customer_service

Comment 29 David Kilzer (:ddkilzer) 2007-08-24 16:46:30 PDT
(In reply to comment #28)
> Apparently they will not fix the issue until Safari 3 is out of beta.  It even
> mentions "(non-beta)" on this page:
> 
> http://www.schwab.com/public/schwab/nn/customer_service/browsers.html?cmsid=P-1414946&lvl1=nn&lvl2=customer_service

BTW, DO NOT download the version of Safari 1.2 linked on this page.  I believe it's for either Jaguar (10.2) or Panther (10.3).

Comment 30 Matt Lilek 2007-08-24 17:13:16 PDT
(In reply to comment #28)
> Apparently they will not fix the issue until Safari 3 is out of beta.

Good thing we're not a Google product or Web 2.0 app then! ;)
Comment 31 Craig Stein 2007-08-29 20:27:24 PDT
The problem appears to be fixed. No more big banners.
Comment 32 Jim Oase 2007-08-29 20:42:44 PDT
Fixed......

thanks

Jim
Comment 33 David Kilzer (:ddkilzer) 2007-08-29 21:14:16 PDT
Resolved as fixed per Comment #31 and Comment #32.