_actionMenuItemsForHitTestResult should also take a type indicating what the menu was built for since HitTestResults that are both images and links could go either way.
Created attachment 240445 [details]
Created attachment 240446 [details]
Oopsie, that wasn't quite right. This one should do it.
Comment on attachment 240446 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=240446&action=review
> +typedef uint32_t WKActionMenuType;
Can you give this an underscore prefix in case we ever want to use this name for something in the modern API?
Thanks Dan! http://trac.webkit.org/changeset/175193