Bug 138014 - In home screen WebApps websql do not response after standyby under IOS 8
Summary: In home screen WebApps websql do not response after standyby under IOS 8
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: iPhone / iPad Unspecified
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-10-23 12:08 PDT by shdev
Modified: 2014-10-23 14:44 PDT (History)
1 user (show)

See Also:


Attachments
It's the same as in the file from the link (2.57 KB, text/html)
2014-10-23 12:08 PDT, shdev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description shdev 2014-10-23 12:08:47 PDT
Created attachment 240361 [details]
It's the same as in the file from the link

I made a WebApp and added it to the home screen. I started it from there. The WebApp uses PouchDB which uses WebSQL. Every time I go to Standby and resumed. The database function don't work. I tested it with a page which only creates one database and give out the rows. After standby it don't work. Under IOS 6.1.6 with an iPod touch 4 32 GB it worked. 

What happens on the page:

* On startup a PouchDB database and a webSQL database will created. (PouchDB uses websql as underlying database)
* on button click it gives out
   - the PouchDB adapters
   - The rows from the websql database
   - the info from the PouchDB database

The PouchDB adapters should not include IndexDB.

Steps to Reproduce:
* Go to http://shdev.github.io/playground/websql.html
* add this page to the home screen
* start it from the home screen
* click the button, three lines appear like descripted above
* standby
* resume


Expected Results:
I would expect there are again 3 lines, like under IOS 6.1.6

Actual Results:
There is only the one line from the PouchDB adapters

Version:
 IOS 8.0.2, IOS 8.1 (both iPhone and iPad)

Notes:
I also tried it without PouchDB the same result. I only use PouchDB to see if something change on the adapters or maybe they use another approach to use the database. If you have question please contact me.

Configuration:
iPhone 4s 16 GB, iPad 3 16 GB
Comment 1 Alexey Proskuryakov 2014-10-23 14:44:06 PDT
This is an issue outside WebKit. It is tracked by Apple internally as rdar://problem/18042389.

Closing as INVALID since it's not a WebKit bug. Thank you for the report!