Bug 13787 - Starcraft 2 website has some navigation issues in ToT
Summary: Starcraft 2 website has some navigation issues in ToT
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://starcraft2.com/features/protoss/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-05-19 16:36 PDT by Brady Eidson
Modified: 2007-12-29 23:39 PST (History)
0 users

See Also:


Attachments
How the first unit detail view (Zealot) looks, and how all of them should look (181.54 KB, image/jpeg)
2007-05-19 16:44 PDT, Brady Eidson
no flags Details
Here's the second unit - notice no unit name and blank area for the unit animation (171.34 KB, image/jpeg)
2007-05-19 16:45 PDT, Brady Eidson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2007-05-19 16:36:26 PDT
This is a Page Loading bug and therefore I should be attacking it and doing reductions and figuring the issues and all that - but I just don't have the time right now...

But, as Starcraft 2 is now public, I predict a lot of interest - I'll be the first to file it ;)

Go to the above url - http://starcraft2.com/features/protoss/

There is a blue navigation section near the top to select from (currently) 4 units and 1 building.  I say currently because the site is in its 1st day live and I predict it will be altered quickly as info about SC2 comes out.

By default, this page is giving you the detailed view on the "Zealot" unit.  There is a heading "Zealot" above the description and a little plugin showing the Zealot 3d model animation.

Click on the 2nd unit in the unit list - should be the "Immortal" unit.  After the navigation, the page should be layed out the same, with "Immortal" replacing "Zealot" and the animation should now be a different unit.

Instead, there is no heading for the new page and the animation area is now blank.

FFX demonstrates the correct and expected behavior

My current WebKit revision is 21600

I hope someone can make a reduction of this pretty soon :)  (I will be able to, but in a few days)
Comment 1 Brady Eidson 2007-05-19 16:37:23 PDT
Since any WoW related bugs are automatically given P1 treatment, I'm tempted to do so here because SC2 will undoubtedly be "WoW"ish in popularity and importance.  

Once the game is released, that is... I'll hold off for now  :)
Comment 2 Brady Eidson 2007-05-19 16:44:30 PDT
Created attachment 14630 [details]
How the first unit detail view (Zealot) looks, and how all of them should look
Comment 3 Brady Eidson 2007-05-19 16:45:10 PDT
Created attachment 14631 [details]
Here's the second unit - notice no unit name and blank area for the unit animation
Comment 4 David Kilzer (:ddkilzer) 2007-05-20 07:53:08 PDT
Another Starcraft II bug:  Bug 13790.  Not sure if they're related or not.

Comment 5 Brady Eidson 2007-05-20 11:30:59 PDT
<rdar://problem/5216119>
Comment 6 Darin Adler 2007-12-29 02:17:02 PST
Looks like the site fixed this a long time ago, and since we don't have anything saved I doubt we can reproduce and fix this.
Comment 7 David Kilzer (:ddkilzer) 2007-12-29 23:39:39 PST
(In reply to comment #6)
> Looks like the site fixed this a long time ago, and since we don't have
> anything saved I doubt we can reproduce and fix this.

The Internet Archive has a page from May 21, 2007 archived:
http://web.archive.org/web/*/http://starcraft2.com/features/protoss/

Unfortunately, I think the archived page relies on some server-side resources (e.g., XMLHTTPRequest), so it still doesn't help.

Marking as RESOLVED/WONTFIX since we can't reproduce the issue anymore.