Bug 13763 - REGRESSION: On pages with multipart resources, Safari never thinks the load completes
Summary: REGRESSION: On pages with multipart resources, Safari never thinks the load c...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://webcam.sewanee.edu/view/view.s...
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-05-17 12:24 PDT by Brady Eidson
Modified: 2007-05-29 12:07 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brady Eidson 2007-05-17 12:24:37 PDT
See the URL http://webcam.sewanee.edu/view/view.shtml for a mpjeg webcam that is fed as a multipart resource.

The progress bar gets stuck around 90% and the spinning progress indicator on the tab never completes.

This broke between 17233 and 17241
Comment 1 Brady Eidson 2007-05-17 12:25:41 PDT
<rdar://problem/5210950>
Comment 2 Brady Eidson 2007-05-17 12:30:08 PDT
Seems *very* likely this was http://trac.webkit.org/projects/webkit/changeset/17238 
http://trac.webkit.org/projects/webkit/changeset/17236 is the only other remotely possible candidate in that range, but 17238 seems most likely by far.

Comment 3 Brady Eidson 2007-05-17 13:13:01 PDT
CC'ing Darin, as it's likely he originally caused the regression
Comment 4 Brady Eidson 2007-05-29 12:07:20 PDT
This was fixed (probably) in http://trac.webkit.org/projects/webkit/changeset/21782