Bug 137522 - [EFL] REGRESSION(r173929): It broke the Web Inspector
Summary: [EFL] REGRESSION(r173929): It broke the Web Inspector
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P1 Critical
Assignee: Gyuyoung Kim
URL:
Keywords:
Depends on:
Blocks: 135120
  Show dependency treegraph
 
Reported: 2014-10-08 07:32 PDT by Csaba Osztrogonác
Modified: 2014-10-17 03:51 PDT (History)
5 users (show)

See Also:


Attachments
WIP (1.27 KB, patch)
2014-10-12 22:26 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff
WIP (2.12 KB, patch)
2014-10-13 00:54 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff
Patch (1.76 KB, patch)
2014-10-15 01:13 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Csaba Osztrogonác 2014-10-08 07:32:08 PDT
After http://trac.webkit.org/changeset/173929 web inspector doesn't work at all in MiniBrowser of EFL.

how to reproduce:
- start MiniBrowser google.com
- right click on anything
- click on inspect element
- nothing happens
Comment 1 Gyuyoung Kim 2014-10-11 07:47:01 PDT
It looks there are two problems on that. One is the "Inspector Element" of context menu doesn't call inspector root function. The other is inspector window isn't shown even when "ctrl + i" shortcut is pressed. Two problems should be fixed.
Comment 2 Gyuyoung Kim 2014-10-12 22:26:09 PDT
Created attachment 239711 [details]
WIP
Comment 3 Gyuyoung Kim 2014-10-12 22:28:34 PDT
I think EFL port needs to implement platformAttach(), platformDetach() and so on in WebInspectorProxyEfl.cpp because r173929 made the WebInspector run on separate web process.
Comment 4 Gyuyoung Kim 2014-10-13 00:54:20 PDT
Created attachment 239714 [details]
WIP
Comment 5 Csaba Osztrogonác 2014-10-13 01:37:40 PDT
just a note: I assume the bug137340  ( DFG-JIT / GC bug ) makes EFL inspector crash too. But you can test the inspector with disabling DFG JIT with JSC_useDFGJIT=0 environment variable.
Comment 6 Gyuyoung Kim 2014-10-15 01:13:23 PDT
Created attachment 239856 [details]
Patch
Comment 7 Gyuyoung Kim 2014-10-15 22:09:49 PDT
Ossy, I think EFL inspector should support docking functionality for inspector window. It looks it may need to spend time for implementing it. So, I wonder whether we can show inspector on new window as before.
Comment 8 Csaba Osztrogonác 2014-10-17 02:09:16 PDT
Comment on attachment 239856 [details]
Patch

LGTM, r=me. This workaround is reasonable until we can add supporting docking.
Comment 9 WebKit Commit Bot 2014-10-17 03:51:13 PDT
Comment on attachment 239856 [details]
Patch

Clearing flags on attachment: 239856

Committed r174820: <http://trac.webkit.org/changeset/174820>
Comment 10 WebKit Commit Bot 2014-10-17 03:51:17 PDT
All reviewed patches have been landed.  Closing bug.