Bug 137327 - [Subpixel] Use floats instead of ints for text justification expansion, and associated cleanup
Summary: [Subpixel] Use floats instead of ints for text justification expansion, and a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
: 137016 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-10-01 17:27 PDT by Myles C. Maxfield
Modified: 2015-01-06 12:11 PST (History)
20 users (show)

See Also:


Attachments
Patch (227.46 KB, patch)
2014-10-01 17:41 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Patch (228.71 KB, patch)
2014-10-01 17:56 PDT, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Patch (199.27 KB, patch)
2014-10-02 11:21 PDT, Myles C. Maxfield
zalan: review+
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2 (505.56 KB, application/zip)
2014-10-02 12:19 PDT, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-02 for mac-mountainlion (512.68 KB, application/zip)
2014-10-02 12:48 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2014-10-01 17:27:36 PDT
[Subpixel] Use floats instead of ints for text justification expansion, and associated cleanup
Comment 1 Myles C. Maxfield 2014-10-01 17:41:09 PDT
Created attachment 239072 [details]
Patch
Comment 2 Myles C. Maxfield 2014-10-01 17:56:59 PDT
Created attachment 239074 [details]
Patch
Comment 3 Myles C. Maxfield 2014-10-02 11:21:07 PDT
Created attachment 239122 [details]
Patch
Comment 4 zalan 2014-10-02 11:33:00 PDT
Comment on attachment 239122 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=239122&action=review

Looks good to me. Andreas, do you think expanding the InlineBox size is still an issue now that we've got simple line layout?

> Source/WebCore/ChangeLog:3
> +        [Subpixel] Use floats instead of ints for text justification expansion, and associated cleanup

minus the "associated cleanup"
Comment 5 Andreas Kling 2014-10-02 11:38:48 PDT
(In reply to comment #4)
> (From update of attachment 239122 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=239122&action=review
> 
> Looks good to me. Andreas, do you think expanding the InlineBox size is still an issue now that we've got simple line layout?

I think it's okay to grow InlineBox a bit. Yay for simple line layout!
Comment 6 zalan 2014-10-02 11:45:25 PDT
Comment on attachment 239122 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=239122&action=review

> Source/WebCore/rendering/InlineBox.h:283
> +    float m_expansion;

Private?
Comment 7 Build Bot 2014-10-02 12:19:05 PDT
Comment on attachment 239122 [details]
Patch

Attachment 239122 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5558973243588608

Number of test failures exceeded the failure limit.
Comment 8 Build Bot 2014-10-02 12:19:12 PDT
Created attachment 239128 [details]
Archive of layout-test-results from webkit-ews-15 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-15  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 9 Build Bot 2014-10-02 12:48:02 PDT
Comment on attachment 239122 [details]
Patch

Attachment 239122 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6574436924784640

Number of test failures exceeded the failure limit.
Comment 10 Build Bot 2014-10-02 12:48:10 PDT
Created attachment 239130 [details]
Archive of layout-test-results from webkit-ews-02 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: webkit-ews-02  Port: mac-mountainlion  Platform: Mac OS X 10.8.5
Comment 11 Myles C. Maxfield 2014-10-02 14:07:59 PDT
Comment on attachment 239122 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=239122&action=review

>> Source/WebCore/ChangeLog:3
>> +        [Subpixel] Use floats instead of ints for text justification expansion, and associated cleanup
> 
> minus the "associated cleanup"

Done.

>> Source/WebCore/rendering/InlineBox.h:283
>> +    float m_expansion;
> 
> Private?

Done.
Comment 12 Myles C. Maxfield 2014-10-02 15:26:26 PDT
http://trac.webkit.org/changeset/174233
Comment 13 Pavel Marakhovski 2014-10-06 02:57:54 PDT
*** Bug 137016 has been marked as a duplicate of this bug. ***
Comment 14 David Kilzer (:ddkilzer) 2015-01-06 12:11:14 PST
<rdar://problem/18549311>