Bug 13725 - REGRESSION: Menu items not restored on mormon.org
Summary: REGRESSION: Menu items not restored on mormon.org
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Major
Assignee: Nobody
URL: http://mormon.org
Keywords: NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-05-14 20:19 PDT by Brandon Petersen
Modified: 2007-08-30 14:12 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brandon Petersen 2007-05-14 20:19:52 PDT
Server error: 
[code=CACHE_FILL_OPEN_FILE] An internal error prevented the object from being sent to the client and cached. Try again later.

Click on "Basic Beliefs". Navigating between the side menu items causes occasional stalls, and produced the above listed server error.
Comment 1 David Kilzer (:ddkilzer) 2007-05-14 22:23:24 PDT
I haven't seen any server errors clicking side-navigation items.  (And even if I didn't, wouldn't this be a server-side bug instead of a client-side bug?)

I did see the following suspect behavior (missing menu items on the side of the page) with a local debug build of WebKit r21447 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135):

* STEPS TO REPRODUCE
1. Open Safari/WebKit.
2. Go to URL: http://mormon.org/
3. Click on "BASIC BELIEFS" link at the top of the page.
4. Click the "HEAVENLY FATHER'S PLAN OF SALVATION" link on the side.
5. Click the "THE RESTORATION OF TRUTH" link on the side.

* EXPECTED RESULTS
Menu items under "THE RESTORATION OF TRUTH" should have been, err...restored to what they looked like when the page first loaded.

* ACTUAL RESUTLS
The menu items under "THE RESTORATION OF TRUTH" were not restored.

* REGRESSION
This works for me in Firefox 2.0.0.3 and Opera 9.10.  There is some kind of fade-in effect for the text, and it appears that it just never fades back in for the top link.  (Other links work fine if hit multiple times.)

Comment 2 David Kilzer (:ddkilzer) 2007-05-14 22:24:56 PDT
(In reply to comment #1)
> I haven't seen any server errors clicking side-navigation items.  (And even if
> I didn't, wouldn't this be a server-side bug instead of a client-side bug?)

So I'm co-opting this bug to investigate the issue I saw in Comment #1.

If you feel that there is a server-side stability issue, please contact the webmaster for the mormon.org web site.  Thanks!

Comment 3 David Kilzer (:ddkilzer) 2007-05-14 22:27:10 PDT
And this is a regression from shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).

Comment 4 Alexey Proskuryakov 2007-05-22 10:52:16 PDT
This site uses jQuery for animations, and running jQuery unit tests, I see opacity-related failures that seem to be in DOM. Not sure if those are actually related to this problem, though (the test failures are not a regression).
Comment 5 Adele Peterson 2007-08-30 14:12:32 PDT
This seems fixed on TOT.  Please reopen if you still have issues.