Bug 137138 - [EFL][WK2] REGRESSION(r136848): W3C SVG 1.1. tests are flaky
Summary: [EFL][WK2] REGRESSION(r136848): W3C SVG 1.1. tests are flaky
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit EFL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 135562 (view as bug list)
Depends on:
Blocks: 104139
  Show dependency treegraph
 
Reported: 2014-09-25 21:09 PDT by Gyuyoung Kim
Modified: 2017-03-11 10:35 PST (History)
7 users (show)

See Also:


Attachments
WIP patch (1.53 KB, patch)
2014-11-03 08:43 PST, Csaba Osztrogonác
no flags Details | Formatted Diff | Diff
absolute-in-relative-overflow-actual.png (38.20 KB, image/png)
2014-11-03 09:05 PST, Csaba Osztrogonác
no flags Details
absolute-in-relative-overflow-expected.png (36.03 KB, image/png)
2014-11-03 09:05 PST, Csaba Osztrogonác
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gyuyoung Kim 2014-09-25 21:09:53 PDT
Below tests are flaky on EFL bots. Need to investigate why below tests are flaky.


  svg/W3C-SVG-1.1-SE/pservers-pattern-03-f.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1-SE/styling-css-04-f.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-07-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-18-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-26-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-30-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-31-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-40-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-62-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-66-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-77-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/animate-elem-81-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/color-prop-01-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/coords-coord-02-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/coords-trans-04-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/coords-viewattr-01-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/extend-namespace-01-f.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/filters-turb-01-f.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/fonts-glyph-02-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/interact-order-02-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/linking-a-02-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/painting-stroke-04-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/paths-data-12-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/paths-data-14-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/paths-data-15-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/pservers-grad-04-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/pservers-grad-09-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/pservers-grad-15-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/pservers-grad-16-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/pservers-grad-19-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/render-elems-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/render-elems-03-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/shapes-ellipse-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-cond-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-defs-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-dom-02-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-dom-04-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-dom-05-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-frag-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-frag-03-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-group-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-image-02-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-image-07-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/struct-use-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/styling-css-02-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/styling-css-04-f.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/styling-inherit-01-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-altglyph-01-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-deco-01-b.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-intro-04-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-intro-05-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-spacing-01-b.svg [ Failure Pass ]
  svg/W3C-SVG-1.1/text-text-04-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-text-05-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-text-06-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/W3C-SVG-1.1/text-ws-01-t.svg [ Failure ImageOnlyFailure Pass ]
  svg/filters/filter-on-filter-for-text.svg [ Failure Pass ]
Comment 1 Csaba Osztrogonác 2014-11-03 04:18:25 PST
The problem is that the actual size is 800x600 somtimes,
but it must be 480x320 for these tests.

Maybe https://trac.webkit.org/changeset/169845 broke
the Coordinated Graphics code path somehow.
Comment 2 Csaba Osztrogonác 2014-11-03 07:04:20 PST
(In reply to comment #1)
> Maybe https://trac.webkit.org/changeset/169845 broke
> the Coordinated Graphics code path somehow.

r169845 is innocent, I managed to reproduce the flakiness before it. (on r169818)
Comment 3 Csaba Osztrogonác 2014-11-03 08:04:49 PST
I got it, http://trac.webkit.org/changeset/136848 is the culprit.
With reverting this change, W3C SVG tests are happy. But it isn't
the real fix, we only replaced one flakiness with an other one.

After r136848 the window is resized to 800x600 after each test
in resetStateToConsistentValues(). The webview is always resized
to 800x600 or 480x360 depends on the filename before each test
via updateWebViewSizeForTest() ( via configureViewForTest() )
Comment 4 Csaba Osztrogonác 2014-11-03 08:43:16 PST
Created attachment 240851 [details]
WIP patch

I think we should move this logic to PlatformWebView::resizeTo() ,
GTK and Mac already use this way.

Unfortunately the original problem is still exist, you can easily reproduce it:
$ Tools/Scripts/run-webkit-tests --efl --no-build --debug-rwt --no-new-test-results --child-processes=1 --no-retry fast/dom/vertical-scrollbar-in-rtl.html fast/regions/absolute-in-relative-overflow.html
Comment 5 Csaba Osztrogonác 2014-11-03 09:05:12 PST
Created attachment 240854 [details]
absolute-in-relative-overflow-actual.png
Comment 6 Csaba Osztrogonác 2014-11-03 09:05:38 PST
Created attachment 240855 [details]
absolute-in-relative-overflow-expected.png
Comment 7 Csaba Osztrogonác 2015-02-05 05:03:13 PST
*** Bug 135562 has been marked as a duplicate of this bug. ***
Comment 8 Michael Catanzaro 2017-03-11 10:35:35 PST
Closing this bug because the EFL port has been removed from trunk.

If you feel this bug applies to a different upstream WebKit port and was closed in error, please either update the title and reopen the bug, or leave a comment to request this.