Bug 137136 - can't load a given webpage
Summary: can't load a given webpage
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.8
: P2 Normal
Assignee: Nobody
URL: https://www.bluecrossma.com/wps/porta...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-25 19:50 PDT by Eric Slosser
Modified: 2015-11-18 15:17 PST (History)
3 users (show)

See Also:


Attachments
screenshot (there is no content below menu) (99.24 KB, image/png)
2014-09-26 22:58 PDT, Alexey Proskuryakov
no flags Details
what Eric sees (191.05 KB, image/png)
2014-09-27 03:41 PDT, Eric Slosser
no flags Details
page rendered IFF console is shown during loading (288.19 KB, image/png)
2014-09-27 05:04 PDT, Eric Slosser
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Slosser 2014-09-25 19:50:17 PDT
https://www.bluecrossma.com/wps/portal/members/using-my-plan/doctors-hospitals/findadoctor/

loads with the shipped Safari, but not with 7.0.6 (9537.78.2, r173946).

(i apologize for not digging deeper)
Comment 1 Alexey Proskuryakov 2014-09-26 22:54:49 PDT
I tried to reproduce this, and I'm not sure if I'm seeing the same issue.

With either Safari 7.0.3 or Safari 7.1, I get a badly corrupted page (will attach a screenshot). But with a nightly, I get a crash. Is the crash what you are seeing?

For Apple employees: the crash appears to be tracked as <rdar://problem/17969740>
Comment 2 Alexey Proskuryakov 2014-09-26 22:58:10 PDT
Created attachment 238762 [details]
screenshot (there is no content below menu)
Comment 3 Eric Slosser 2014-09-27 03:37:27 PDT
Nope, no crash.  I still get <see screenshot>
Comment 4 Eric Slosser 2014-09-27 03:41:34 PDT
Created attachment 238770 [details]
what Eric sees
Comment 5 Eric Slosser 2014-09-27 05:02:37 PDT
With  7.0.6 (9537.78.2, r174032 (and perhaps the original older nightly I first reported), the page renders IFF the web inspector is displayed.  The page looks like attachment "...eric2.png".

The console holds:
[Log] isRegistration : False (findadoctor, line 128)
[Log] handleCookie() Called (findadoctor, line 137)
[Warning] Invalid CSS property declaration at: #zoom (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #display (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #vertical-align (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #zoom (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #display (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #zoom (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #display (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #vertical-align (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #overflow (tundra.css, line 1, x2)
[Warning] Invalid CSS property declaration at: #vertical-align (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #zoom (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #display (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #background (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #display (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #background-image (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: #zoom (tundra.css, line 1)
[Warning] Invalid CSS property declaration at: * (styles.jsp, line 214)
[Warning] Invalid CSS property declaration at: * (styles.jsp, line 231)
[Warning] Invalid CSS property declaration at: * (styles.jsp, line 248)
[Warning] Invalid CSS property declaration at: * (styles.jsp, line 280)
[Warning] Invalid CSS property declaration at: * (styles.jsp, line 296)
[Warning] Unexpected CSS token: : (styles.jsp, line 1792)
[Warning] Invalid CSS property declaration at: #background (styles.jsp, line 2026)
[Warning] Unexpected CSS token: : (styles.jsp, line 2713)
[Error] TypeError: undefined is not an object (evaluating 'ibm.portal.ThemeImages.errorGifPath')
	constructor (undefined, line 214)
	_construct (js.jsp, line 203)
	(anonymous function) (js.jsp, line 203)
	global code (findadoctor, line 1089)
[Warning] Unexpected CSS token: = (findadoctor, line 3600)
[Warning] Unexpected CSS token: ; (findadoctor, line 3601)
[Warning] Invalid CSS property declaration at: 11px (findadoctor, line 3601)
[Warning] Unexpected CSS token: = (findadoctor, line 3606)
[Warning] Unexpected CSS token: ; (findadoctor, line 3607)
[Warning] Invalid CSS property declaration at: 11px (findadoctor, line 3607)
[Warning] The page at https://www.bluecrossma.com/wps/portal/members/using-my-plan/doctors-hospitals/findadoctor/ displayed insecure content from http://www.bluecrossma.com/medicare-options/images/new_medicare_site/pdf-white.gif. (findadoctor, line 3955)

[Error] TypeError: undefined is not an object (evaluating 'wa.URLchunk1.indexOf')
	global code (ntpagetag.js, line 159)
Comment 6 Eric Slosser 2014-09-27 05:04:40 PDT
Created attachment 238774 [details]
page rendered IFF console is shown during loading

console was displayed during loading, but hidden prior to taking the screen shot.
Comment 7 Alexey Proskuryakov 2014-09-27 12:55:52 PDT
"A problem repeatedly occurred" is an euphemism for a crash happening every time on page load. It is theoretically possible that WebContent cleanly (yet unexpectedly) exits without crashing, but that's extremely rare, I don't think that I've seen a bug like that before in practice. Can you find any crash logs in Console that would correspond to opening this page?

The fact that this works with Inspector open further reinforces my guess that it's a JavaScript JIT bug - these often go away with Inspector open.

I figured out why this site doesn't work for me - turns out that it breaks when OS X system language is set to Russian (and thus HTTP Accept-Language header field value is "ru"). It is unrelated to this bug.

One other thing, probably not directly related to this bug - I see Safari 7.0.6 on your screenshot. We only intend to support the latest Safari release with nightlies, which is currently 7.1 (or 6.2 on Mountain Lion).
Comment 8 Brian Burg 2015-11-18 15:17:15 PST
This has been fixed in the past year. <rdar://problem/17969740>