Bug 13695 - REGRESSION (r21387): Replaced elements' highlight rects are wrongly positioned
Summary: REGRESSION (r21387): Replaced elements' highlight rects are wrongly positioned
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: LayoutTestFailure, Regression
Depends on:
Blocks:
 
Reported: 2007-05-12 02:08 PDT by mitz
Modified: 2007-05-12 19:53 PDT (History)
1 user (show)

See Also:


Attachments
Test case (186 bytes, text/html)
2007-05-12 02:08 PDT, mitz
no flags Details
Pass off the rect in local coordinates to computeAbsoluteRepaintRect() (8.92 KB, patch)
2007-05-12 02:37 PDT, mitz
no flags Details | Formatted Diff | Diff
Pass off the rect in local coordinates to computeAbsoluteRepaintRect() (10.13 KB, patch)
2007-05-12 03:03 PDT, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2007-05-12 02:08:08 PDT
See the attached test case. Looks like the offset within the containing block is being added twice.
Comment 1 mitz 2007-05-12 02:08:37 PDT
Created attachment 14509 [details]
Test case
Comment 2 mitz 2007-05-12 02:37:31 PDT
Created attachment 14510 [details]
Pass off the rect in local coordinates to computeAbsoluteRepaintRect()
Comment 3 mitz 2007-05-12 02:40:26 PDT
Comment on attachment 14510 [details]
Pass off the rect in local coordinates to computeAbsoluteRepaintRect()

RenderListMarker probably needs the same fix, so I'll try to add that.
Comment 4 mitz 2007-05-12 03:03:32 PDT
Created attachment 14512 [details]
Pass off the rect in local coordinates to computeAbsoluteRepaintRect()

Also fixes the list marker regression, which was detected by an existing pixel test!
Comment 5 Dave Hyatt 2007-05-12 03:09:45 PDT
Comment on attachment 14512 [details]
Pass off the rect in local coordinates to computeAbsoluteRepaintRect()

r=me
Comment 6 mitz 2007-05-12 03:34:04 PDT
Actually, the image bug was also covered by a pixel test, fast/overflow/image-selection-highlight.html but it's good to have the new test for the no-overflow case too.
Comment 7 Sam Weinig 2007-05-12 19:53:31 PDT
Landed in r21436.