Bug 136937 - IndexedDB transaction throw error for multiple object store
Summary: IndexedDB transaction throw error for multiple object store
Status: RESOLVED DUPLICATE of bug 149117
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.9
: P2 Normal
Assignee: Nobody
URL: http://dev.yathit.com/ydn-db/test/iss...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-09-18 20:42 PDT by Kyaw
Modified: 2016-01-12 09:12 PST (History)
16 users (show)

See Also:


Attachments
reproduce the issue (1.27 KB, text/html)
2014-09-18 20:42 PDT, Kyaw
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kyaw 2014-09-18 20:42:03 PDT
Created attachment 238349 [details]
reproduce the issue

Steps to Reproduce:
1. Load the attached HTML file to localhost server or http://dev.yathit.com/ydn-db/test/issues/issue-github-20.html
2. Open the file in Safari 7.1 which has indexedDB
3. You will see NotFoundError: DOM IDBDatabase Exception 8: 
4. Verify that it is working in Chrome or Firefox
5. Change as suggested in line number 24, from multiple stores to single store.
6. Verify it work in Safari.
Comment 1 Etienne Lemay 2014-12-08 12:09:58 PST
Has this been acknowledged yet? According to the specs a transaction should be able to interact with multiple object stores. http://www.w3.org/TR/IndexedDB/#dfn-scope
Comment 2 jim.trainor.kanata 2015-01-16 06:16:06 PST
Safari 8.0.2 still exhibits this problem.

I hit this bug in existing code that I've been running in Chrome without problem for a couple of years. Been waiting to port it to Safari... just tried.. no go as is due to this bug.
Comment 3 fcheslack 2015-02-25 13:06:50 PST
Any movement on this? Is more information needed? This seems like it would break a large number of web apps, and is more problematic than having no IndexedDB support at all.
Comment 4 Radar WebKit Bug Importer 2015-02-27 09:19:47 PST
<rdar://problem/19984978>
Comment 5 David Kilzer (:ddkilzer) 2015-03-11 10:38:01 PDT
<rdar://problem/18151360>
Comment 6 Thibaut Courouble 2016-01-11 15:17:40 PST
This is a major bug making IndexedDB unusable for any non-trivial use-case. Please fix.
Comment 7 hawkrives+webkit 2016-01-12 07:40:09 PST
The bug is still present in Safari 9.0.2, reproducible with the test case.

However! Good news!

As of WebKit Nightly r194890 (roughly 2016-01-12), I cannot reproduce this issue with the provided test case.
Comment 8 Brady Eidson 2016-01-12 09:12:26 PST
(In reply to comment #7)
> The bug is still present in Safari 9.0.2, reproducible with the test case.
> 
> However! Good news!
> 
> As of WebKit Nightly r194890 (roughly 2016-01-12), I cannot reproduce this
> issue with the provided test case.

That's actually really surprising, assuming you launched Safari using the WebKit nightly and tried it in-browser.

This is because the work for Modern IDB has been WebKit1 only so far, while Safari uses WebKit2.

BUT, if you're developing a WebKit app that uses WebKit1, and use it against the WebKit nightly, that would explain why it works.

Anyways, I'm closing this bug as a dupe of the Modern IDB bug.
Comment 9 Brady Eidson 2016-01-12 09:12:45 PST

*** This bug has been marked as a duplicate of bug 149117 ***