Bug 136779 - Remove shouldAbortEarly cruft from master.cfg
Summary: Remove shouldAbortEarly cruft from master.cfg
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-12 05:09 PDT by Éva Balázsfalvi
Modified: 2014-09-16 01:16 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.59 KB, patch)
2014-09-12 05:12 PDT, Éva Balázsfalvi
no flags Details | Formatted Diff | Diff
Patch (2.71 KB, patch)
2014-09-15 07:15 PDT, Éva Balázsfalvi
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Éva Balázsfalvi 2014-09-12 05:09:34 PDT
All bots abort after 50 crashes or 500 failures, nobody uses this feature.
Comment 1 Éva Balázsfalvi 2014-09-12 05:12:57 PDT
Created attachment 238022 [details]
Patch
Comment 2 Csaba Osztrogonác 2014-09-12 09:05:16 PDT
Comment on attachment 238022 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=238022&action=review

> Tools/BuildSlaveSupport/build.webkit.org-config/master.cfg:-381
> -            self.setCommand(self.command + ["--exit-after-n-crashes-or-timeouts", "50", "--exit-after-n-failures", "500"])

This line shouldn't be removed, we need --exit-after-* unconditionally. (shouldAbortEarly is always True)
Comment 3 Éva Balázsfalvi 2014-09-15 07:15:00 PDT
Created attachment 238126 [details]
Patch
Comment 4 Csaba Osztrogonác 2014-09-16 01:09:42 PDT
This property was introduced in http://trac.webkit.org/changeset/126044 and
the WTR bug was fixed by http://trac.webkit.org/changeset/126418 in 3 days.
It happened 2 years before, since then we didn't need this hack to make bots
not to exit early. So let's remove it.

On a serious regression exit after 50 timeout is really necessary until the
culprit patch is rolled out. 50 timeouts take 50*35s = 1750s = 29.16mins on
WK1 and 50*80s = 66.66mins on WK2. If we disabled the early exit, it would 
cause infinite builds on the bots.

If we will really need this hack in the future, I prefer adding 
it back as per builder configurable option, like SVNMirror.
Comment 5 WebKit Commit Bot 2014-09-16 01:16:49 PDT
Comment on attachment 238126 [details]
Patch

Clearing flags on attachment: 238126

Committed r173653: <http://trac.webkit.org/changeset/173653>
Comment 6 WebKit Commit Bot 2014-09-16 01:16:52 PDT
All reviewed patches have been landed.  Closing bug.