Bug 136595 - input[required] does nothing
Summary: input[required] does nothing
Status: RESOLVED DUPLICATE of bug 28649
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P2 Normal
Assignee: Nobody
URL: http://www.w3.org/TR/html5/forms.html...
Keywords: HTML5
Depends on:
Blocks:
 
Reported: 2014-09-05 23:03 PDT by andrew.roazen
Modified: 2016-06-24 08:45 PDT (History)
1 user (show)

See Also:


Attachments
HTML test page for required attribute (760 bytes, text/html)
2014-09-05 23:03 PDT, andrew.roazen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrew.roazen 2014-09-05 23:03:46 PDT
Created attachment 237730 [details]
HTML test page for required attribute

The "required" attribute on INPUT elements is expected to interrupt form submission when no user input has been supplied. This behavior is demonstrable in other browser cores and even the GTK webcore has error messages for this condition supplied as of December 2013.
Comment 1 Alexey Proskuryakov 2014-09-08 23:29:25 PDT

*** This bug has been marked as a duplicate of bug 28649 ***