Bug 13645 - JSEnv bookmarklet doesn't print errors
Summary: JSEnv bookmarklet doesn't print errors
Status: RESOLVED DUPLICATE of bug 8519
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 419.x
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.squarefree.com/jsenv/
Keywords:
Depends on:
Blocks: 8456
  Show dependency treegraph
 
Reported: 2007-05-09 10:25 PDT by Garrett Smith
Modified: 2007-05-13 08:49 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Garrett Smith 2007-05-09 10:25:29 PDT
JSEnv is a very useful development bookmarklet that does not work in Safari.

I don't expect the feature "install as user script" to work.

However, JSEnv cannot run a simple script in Safari.

Try in FireFox to see how it should work.
Comment 1 Sam Weinig 2007-05-09 13:29:30 PDT
Hi Garrett, JSEnv seems to work fine in the nightlies.  If you are seeing a particular problem please reopen the bug.  Thanks for the report though. 
Comment 2 Garrett Smith 2007-05-09 15:55:43 PDT
Much better in the nightly. However, running the example in Safari, the failure case has a different Result: The error does not make it to the console, as it does in FireFox. I didn't try to find out why the failure test failed.


In firefox:
================================================
Running...
Squares of numbers 0 through 4:
0
1
4
9
16
Error on line 11: this.statement has no properties
================================================
In safari:
================================================
Running...
Squares of numbers 0 through 4:
0
1
4
9
16
================================================

Comment 3 David Kilzer (:ddkilzer) 2007-05-12 10:42:22 PDT
Confirmed with a local debug build of WebKit r21332 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).

JavaScript console reports (when running the "failure" test):

TypeError: Undefined value
Line: 11

Comment 4 Alexey Proskuryakov 2007-05-13 08:49:02 PDT
This problem is caused by window.onerror not working in WebKit, closing as a duplicate.

Thank you for reporting this! Please file new bugs if you find any other problems with this bookmarklet.

*** This bug has been marked as a duplicate of 8519 ***