Bug 136255 - REGRESSION(r172835) [GTK] Layout Test fast/block/float/overhanging-tall-block.html is failing
Summary: REGRESSION(r172835) [GTK] Layout Test fast/block/float/overhanging-tall-block...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-26 09:41 PDT by Carlos Alberto Lopez Perez
Modified: 2024-05-28 23:33 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Alberto Lopez Perez 2014-08-26 09:41:44 PDT
Revision r172835 <http://trac.webkit.org/r172835> (Enable SATURATED_LAYOUT_ARITHMETIC) made the layout test fast/block/float/overhanging-tall-block.html fail on platform GTK

 * Actual result: http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r172842%20%282253%29/fast/block/float/overhanging-tall-block-actual.txt
 * Expected result: http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r172842%20%282253%29/fast/block/float/overhanging-tall-block-expected.txt
 * Pretty diff: http://build.webkit.org/results/GTK%20Linux%2064-bit%20Release%20%28Tests%29/r172842%20%282253%29/fast/block/float/overhanging-tall-block-pretty-diff.html

I tried to revert r172835 locally and the test passes...

I don't know if the diff is indicative of a bug, or the expected result just needs to be rebaselined.

Any opinion?
Comment 1 Diego Pino 2024-05-28 23:32:55 PDT
This test has been consistenly passing since 275882@main (updated baseline for this test).

https://results.webkit.org/?platform=GTK&platform=WPE&suite=layout-tests&test=editing%2Fdeleting%2Fdelete-by-word-001.html

After updating test expectations in 279290@main, there are no more tests referring to this bug. Closing bug.