Bug 136120 - WebAudio FFT analysis uses incorrect scaling
Summary: WebAudio FFT analysis uses incorrect scaling
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dean Jackson
URL:
Keywords:
: 135986 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-20 15:18 PDT by Dean Jackson
Modified: 2014-08-20 17:54 PDT (History)
7 users (show)

See Also:


Attachments
Patch (7.70 KB, patch)
2014-08-20 15:26 PDT, Dean Jackson
thorton: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dean Jackson 2014-08-20 15:18:38 PDT
WebAudio FFT analysis uses incorrect scaling
Comment 1 Dean Jackson 2014-08-20 15:26:53 PDT
Created attachment 236900 [details]
Patch
Comment 2 Tim Horton 2014-08-20 15:31:40 PDT
Comment on attachment 236900 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=236900&action=review

> Source/WebCore/ChangeLog:18
> +        When this test is run using an older version of Chrome, the peak varies

Chrome!

> LayoutTests/webaudio/realtimeanalyser-fft-scaling.html:33
> +      function checkResult() {

function body is not indented?
Comment 3 Alexey Proskuryakov 2014-08-20 17:54:04 PDT
*** Bug 135986 has been marked as a duplicate of this bug. ***
Comment 4 Dean Jackson 2014-08-20 17:54:37 PDT
Committed r172816: <http://trac.webkit.org/changeset/172816>