Bug 136102 - [GTK] Add the Wayland protocol extension
Summary: [GTK] Add the Wayland protocol extension
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Zan Dobersek
Depends on:
Blocks: 115803
  Show dependency treegraph
Reported: 2014-08-20 07:28 PDT by Zan Dobersek
Modified: 2014-08-28 01:04 PDT (History)
6 users (show)

See Also:

Patch (4.10 KB, patch)
2014-08-20 07:46 PDT, Zan Dobersek
no flags Details | Formatted Diff | Diff
Patch (4.25 KB, patch)
2014-08-20 09:06 PDT, Zan Dobersek
mrobinson: review+
mrobinson: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zan Dobersek 2014-08-20 07:28:30 PDT
[GTK] Add the Wayland protocol extension
Comment 1 Zan Dobersek 2014-08-20 07:46:36 PDT
Created attachment 236870 [details]
Comment 2 Martin Robinson 2014-08-20 08:45:06 PDT
Comment on attachment 236870 [details]

I think wl-wkgtk.xml should probably have a name that reflects what we typically do with C++ source files, descriptive and using non-abbreviated words when possible. Why not WebKitGtkWaylandClientProtocol.xml producing WebKitGtkWaylandClientProtocol.c (notice the flipped words from the existing name).
Comment 3 Zan Dobersek 2014-08-20 08:56:19 PDT
Yeah, that works better.
Comment 4 Zan Dobersek 2014-08-20 09:06:24 PDT
Created attachment 236872 [details]
Comment 5 Martin Robinson 2014-08-20 09:15:50 PDT
Comment on attachment 236872 [details]

View in context: https://bugs.webkit.org/attachment.cgi?id=236872&action=review

Thanks! Please do one more rename before landing.

> Source/WebCore/platform/graphics/wayland/WebKitGtkWaylandClientProtocol.xml:2
> +<protocol name="wl_wkgtk">

Probably should rename this to wl_webkitgtk as well.

> Source/WebCore/platform/graphics/wayland/WebKitGtkWaylandClientProtocol.xml:29
> +  <interface name="wl_wkgtk" version="1">

Comment 6 Zan Dobersek 2014-08-22 01:20:38 PDT
Committed r172856: <http://trac.webkit.org/changeset/172856>