Bug 13608 - Text does not appear on this page
Summary: Text does not appear on this page
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.ssqq.com/archive/vinlin19....
Keywords: HasReduction
: 14496 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-05-07 01:11 PDT by Eric Seidel (no email)
Modified: 2007-07-02 10:17 PDT (History)
2 users (show)

See Also:


Attachments
Partial reduction (231 bytes, text/html)
2007-05-07 02:55 PDT, Charles Gaudette
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-05-07 01:11:10 PDT
The text appears fine in FireFox but does not work in Safari.

http://www.ssqq.com/archive/vinlin19.htm?
Comment 1 mitz 2007-05-07 02:27:46 PDT
Reduction: this is transparent in WebKit, but black in Firefox 2 and Opera:
<span style="color: transparent;">Invisible text</span>
Comment 2 Dave Hyatt 2007-05-07 02:43:52 PDT
Not a bug.  We support the CSS3 keyword transparent.  The other browsers are still stuck in CSS2.

Comment 3 Charles Gaudette 2007-05-07 02:55:18 PDT
Created attachment 14386 [details]
Partial reduction

This partial reduction shows that the issue is to be found in the CSS.

http://www.ssqq.com/archive/_themes/cypress/cypr1011.css
Comment 4 Dave Hyatt 2007-05-07 02:58:23 PDT
http://www.w3.org/TR/2003/CR-css3-color-20030514/#transparent

" The Open eBook(tm) Publication Structure 1.0.1 [OEB101] extended the 'color' property to also accept the 'transparent' keyword. CSS3 extends the color value to include the 'transparent' keyword to allow its use with all properties that accept a <color> value. This simplifies the definition of those properties in CSS3."
Comment 5 Charles Gaudette 2007-05-07 03:00:55 PDT
(In reply to comment #3)
Ack! Nevermind. I did not see other comments resolving this bug.

Comment 6 mitz 2007-07-02 10:17:41 PDT
*** Bug 14496 has been marked as a duplicate of this bug. ***