Bug 135971 - Fix gliding in AxisScrollSnapAnimator for Mac
Summary: Fix gliding in AxisScrollSnapAnimator for Mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Unspecified
: P2 Enhancement
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 135774
  Show dependency treegraph
 
Reported: 2014-08-15 01:57 PDT by Wenson Hsieh
Modified: 2014-08-15 16:35 PDT (History)
1 user (show)

See Also:


Attachments
Patch (6.26 KB, patch)
2014-08-15 15:27 PDT, Wenson Hsieh
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Wenson Hsieh 2014-08-15 01:57:12 PDT
After finishing animation to a snap point due to a a flick gesture, leftover momentum events that are handled by the AxisScrollSnapAnimator are incorrectly pushed to the momentum tracking window, occasionally causing a second extremely slow gliding animation to take place after reaching the intended snap point. This is fixed by distinguishing the Idle state due to user interaction from the Idle state caused by reaching the intended snap point.
Comment 1 Wenson Hsieh 2014-08-15 15:27:32 PDT
Created attachment 236679 [details]
Patch
Comment 2 WebKit Commit Bot 2014-08-15 16:35:35 PDT
Comment on attachment 236679 [details]
Patch

Clearing flags on attachment: 236679

Committed r172659: <http://trac.webkit.org/changeset/172659>
Comment 3 WebKit Commit Bot 2014-08-15 16:35:38 PDT
All reviewed patches have been landed.  Closing bug.