Bug 135934 - [GTK] REGRESSION(r171598, CMake): Introspection files are installed at the wrong path
Summary: [GTK] REGRESSION(r171598, CMake): Introspection files are installed at the wr...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Regression
Depends on:
Blocks:
 
Reported: 2014-08-14 03:03 PDT by Carlos Garcia Campos
Modified: 2014-08-14 06:11 PDT (History)
8 users (show)

See Also:


Attachments
Patch (3.38 KB, patch)
2014-08-14 03:10 PDT, Carlos Garcia Campos
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2014-08-14 03:03:10 PDT
Since r171598 gir files are installed under $datadir/webkitgtk-4.0/gir-1.0/. The gir files should installed in $datadir/gir-1.0/ together with all other gir files. We don't need to install introspection files in a versioned directory because their filenames already contain the binary version. But before r171598, the files were only installed to the right directory if the gobject-instrospection pkg-config file was in the same prefix than the one we wanted to install, because the gir and typelibs directories were extracted from the pkg-config file. We should define INTROSPECTION_INSTALL_GIRDIR and INTROSPECTION_INSTALL_TYPELIBDIR in OptionsGTK.cmake based on $datadir and $libdir like we do in the autotools build (grep for girdir and typelibsdir in GNUmakefile.am)
Comment 1 Carlos Garcia Campos 2014-08-14 03:09:22 PDT
See also https://bugzilla.gnome.org/show_bug.cgi?id=734327
Comment 2 Carlos Garcia Campos 2014-08-14 03:10:12 PDT
Created attachment 236585 [details]
Patch
Comment 3 Gustavo Noronha (kov) 2014-08-14 06:06:40 PDT
Comment on attachment 236585 [details]
Patch

Yeah, I think that makes sense.
Comment 4 Carlos Garcia Campos 2014-08-14 06:11:01 PDT
Committed r172583: <http://trac.webkit.org/changeset/172583>