Bug 135744 - commit-log-message has extra blank line at the top of pre-populated message
Summary: commit-log-message has extra blank line at the top of pre-populated message
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-07 21:35 PDT by Joseph Pecoraro
Modified: 2014-08-08 01:09 PDT (History)
6 users (show)

See Also:


Attachments
[PATCH] Proposed Fix (3.26 KB, patch)
2014-08-07 21:51 PDT, Joseph Pecoraro
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2014-08-07 21:35:10 PDT
* SUMMARY
commit-log-message has extra blank line at the top of pre-populated message.

* NOTES
Caused by: <https://webkit.org/b/131727> Fix the commit-log-editor after r167243 and add more unit tests

My work flow is something like:

   1. Make change
   2. git add files
   3. prepare-ChangeLog --git-index
   4. git add ChangeLogs
   5. git commit
    => extra newline
Comment 1 Joseph Pecoraro 2014-08-07 21:41:13 PDT
In my case, I have a single ChangeLog entry, so the $commonPrefix is empty. The extra newline gets added because of:

>       if (!$commonPrefix) {
>           push @result, normalizeLineEndings("\n", $endl);
>       }
Comment 2 Joseph Pecoraro 2014-08-07 21:51:18 PDT
Created attachment 236264 [details]
[PATCH] Proposed Fix
Comment 3 Csaba Osztrogonác 2014-08-08 00:36:37 PDT
Comment on attachment 236264 [details]
[PATCH] Proposed Fix

Sorry for the trouble and thanks for the fix. r=me.
Comment 4 WebKit Commit Bot 2014-08-08 01:09:27 PDT
Comment on attachment 236264 [details]
[PATCH] Proposed Fix

Clearing flags on attachment: 236264

Committed r172339: <http://trac.webkit.org/changeset/172339>
Comment 5 WebKit Commit Bot 2014-08-08 01:09:30 PDT
All reviewed patches have been landed.  Closing bug.