Bug 135730 - [Mac] Parental Controls content filter is mistakenly enabled for HTTP responses
Summary: [Mac] Parental Controls content filter is mistakenly enabled for HTTP responses
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andy Estes
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-08-07 15:13 PDT by Andy Estes
Modified: 2014-08-07 15:27 PDT (History)
3 users (show)

See Also:


Attachments
Patch (3.71 KB, patch)
2014-08-07 15:19 PDT, Andy Estes
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Estes 2014-08-07 15:13:34 PDT
[Mac] Parental Controls content filter is mistakenly enabled for HTTP responses
Comment 1 Andy Estes 2014-08-07 15:14:08 PDT
<rdar://problem/16567659>
Comment 2 Andy Estes 2014-08-07 15:19:40 PDT
Created attachment 236235 [details]
Patch
Comment 3 Andy Estes 2014-08-07 15:21:57 PDT
Comment on attachment 236235 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=236235&action=review

> Source/WebCore/ChangeLog:11
> +        pre-upstreaming behavior and only enable the content filter for HTTP responses.

ChangeLog typo: "... only enable the content filter for HTTPS responses."
Comment 4 Andy Estes 2014-08-07 15:27:38 PDT
Committed r172293: <http://trac.webkit.org/changeset/172293>