Bug 135695 - [GTK] Use WebKitNavigationAction also for WebKitNavigationPolicyDecision
Summary: [GTK] Use WebKitNavigationAction also for WebKitNavigationPolicyDecision
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKitGTK (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks:
 
Reported: 2014-08-07 01:52 PDT by Carlos Garcia Campos
Modified: 2014-08-07 07:58 PDT (History)
9 users (show)

See Also:


Attachments
Patch (33.50 KB, patch)
2014-08-07 02:09 PDT, Carlos Garcia Campos
gustavo: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2014-08-07 01:52:05 PDT
WebKitNavigationAction was introduced to extend WebKitWebView::create signal. Its API is mostly duplicated in WebKitNavigationPolicyDecision, so we can deprecate the duplicated methods and add webkit_navigation_policy_decision_get_navigation_data. This also makes it possible to know whether a navigation policy decision was triggered by a user gesture.
Comment 1 Carlos Garcia Campos 2014-08-07 02:09:01 PDT
Created attachment 236181 [details]
Patch
Comment 2 WebKit Commit Bot 2014-08-07 02:10:50 PDT
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 WebKit Commit Bot 2014-08-07 02:11:01 PDT
Attachment 236181 [details] did not pass style-queue:


WARNING: File exempt from style guide. Skipping: "Source/WebKit2/UIProcess/API/gtk/WebKitNavigationPolicyDecision.h"
WARNING: File exempt from style guide. Skipping: "Source/WebKit2/UIProcess/API/gtk/WebKitDefines.h"
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitPolicyClient.cpp:47:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
ERROR: Source/WebKit2/UIProcess/API/gtk/WebKitPolicyClient.cpp:53:  The parameter type should use PassRefPtr instead of RefPtr.  [readability/pass_ptr] [5]
Total errors found: 2 in 13 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Carlos Garcia Campos 2014-08-07 07:58:35 PDT
Committed r172211: <http://trac.webkit.org/changeset/172211>