Bug 135478 - [Win] Use RC_PROJECTBUILDVERSION as build portion of version
Summary: [Win] Use RC_PROJECTBUILDVERSION as build portion of version
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Brent Fulgham
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-07-31 15:22 PDT by Brent Fulgham
Modified: 2014-07-31 18:16 PDT (History)
2 users (show)

See Also:


Attachments
Patch (2.11 KB, patch)
2014-07-31 15:28 PDT, Brent Fulgham
ddkilzer: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Brent Fulgham 2014-07-31 15:22:46 PDT
We want to make sure that the environment variable 'RC_PROJECTBUILDVERSION' is used (when available) to populate the FILE version of the version resource.
Comment 1 Brent Fulgham 2014-07-31 15:28:47 PDT
Created attachment 235854 [details]
Patch
Comment 2 Radar WebKit Bug Importer 2014-07-31 16:12:43 PDT
<rdar://problem/17877481>
Comment 3 David Kilzer (:ddkilzer) 2014-07-31 16:42:30 PDT
Comment on attachment 235854 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=235854&action=review

r=me either way

Also, can we write a test for SAFE_BUILD_VERSION being defined in the environment to test the override?

> WebKitLibraries/win/tools/scripts/version-stamp.pl:103
> +my $SAFE_BUILD_VERSION = $ENV{RC_PROJECTBUILDVERSION};
> +if (!defined($SAFE_BUILD_VERSION)) {
> +    $SAFE_BUILD_VERSION = $components{'__VERSION_BUILD__'};
> +}

I would prefer to write this code thusly:

my $SAFE_BUILD_VERSION = $ENV{RC_PROJECTBUILDVERSION} || $components{'__VERSION_BUILD__'};

I think it's a lot easier to read that way.  :)
Comment 4 Brent Fulgham 2014-07-31 17:18:38 PDT
Comment on attachment 235854 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=235854&action=review

>> WebKitLibraries/win/tools/scripts/version-stamp.pl:103
>> +}
> 
> I would prefer to write this code thusly:
> 
> my $SAFE_BUILD_VERSION = $ENV{RC_PROJECTBUILDVERSION} || $components{'__VERSION_BUILD__'};
> 
> I think it's a lot easier to read that way.  :)

Will do.
Comment 5 Brent Fulgham 2014-07-31 18:16:16 PDT
Committed r171903: <http://trac.webkit.org/changeset/171903>