Bug 13540 - REGRESSION: Reproducible ASSERT closing page with streaming jpeg webcam
Summary: REGRESSION: Reproducible ASSERT closing page with streaming jpeg webcam
Status: RESOLVED DUPLICATE of bug 13360
Alias: None
Product: WebKit
Classification: Unclassified
Component: Page Loading (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.scheveningenlive.nl/beach1...
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-04-29 02:29 PDT by David Kilzer (:ddkilzer)
Modified: 2007-04-29 03:19 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2007-04-29 02:29:59 PDT
* SUMMARY
Closing a page with a streaming jpeg webcam causes an assertion failure in debug builds of ToT WebKit.

* STEPS TO REPRODUCE
1. Open Safari/WebKit.
2. Load URL:  http://www.scheveningenlive.nl/beach1.html
3. Close window.

* EXPECTED RESULTS
Window should close without assertion failure.

* ACTUAL RESULTS
Assertion failure occurs when closing window.

* REGRESSION
Not tested with shipping Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135) yet.

* NOTES
Reproduced with a local debug build of WebKit r21170 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).
Comment 1 David Kilzer (:ddkilzer) 2007-04-29 02:32:11 PDT
This does not occur with shipping Safari, although it's not a debug build.

Comment 2 David Kilzer (:ddkilzer) 2007-04-29 03:02:19 PDT
Console output:

[28500] http://www.scheveningenlive.nl/beach1.html line 351: TypeError: Undefined value
(event handler):Can't find variable: begintimer
Corrupt JPEG data: premature end of data segment
Corrupt JPEG data: premature end of data segment
Corrupt JPEG data: premature end of data segment
ASSERTION FAILED: m_loadingResources.contains(identifier)
(/Volumes/Data/WebKit/WebKit/WebView/WebDocumentLoaderMac.mm:93 decreaseLoadCount)
Segmentation fault

Stack trace:

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xbbadbeef

Thread 0 Crashed:
0   com.apple.WebKit         	0x003c28a8 WebDocumentLoaderMac::decreaseLoadCount(unsigned long) + 120 (WebDocumentLoaderMac.mm:93)
1   com.apple.WebKit         	0x003c6fac WebFrameLoaderClient::dispatchDidFailLoading(WebCore::DocumentLoader*, unsigned long, WebCore::ResourceError const&) + 316
2   com.apple.WebCore        	0x0146b6fc WebCore::FrameLoader::didFailToLoad(WebCore::ResourceLoader*, WebCore::ResourceError const&) + 252 (FrameLoader.cpp:3154)
3   com.apple.WebCore        	0x014845c0 WebCore::ResourceLoader::didCancel(WebCore::ResourceError const&) + 448
4   com.apple.WebCore        	0x014858f4 WebCore::SubresourceLoader::didCancel(WebCore::ResourceError const&) + 268 (SubresourceLoader.cpp:235)
5   com.apple.WebCore        	0x01483f20 WebCore::ResourceLoader::cancel(WebCore::ResourceError const&) + 156
6   com.apple.WebCore        	0x01483fe4 WebCore::ResourceLoader::cancel() + 68
7   com.apple.WebCore        	0x014805e0 WebCore::cancelAll(WTF::HashSet<WTF::RefPtr<WebCore::ResourceLoader>, WTF::PtrHash<WTF::RefPtr<WebCore::ResourceLoader> >, WTF::HashTraits<WTF::RefPtr<WebCore::ResourceLoader> > > const&) + 108 (DocumentLoader.cpp:111)
8   com.apple.WebCore        	0x01480668 WebCore::DocumentLoader::stopLoadingSubresources() + 40 (DocumentLoader.cpp:626)
9   com.apple.WebCore        	0x01480aac WebCore::DocumentLoader::stopLoading() + 532 (DocumentLoader.cpp:290)
10  com.apple.WebCore        	0x01474aa4 WebCore::FrameLoader::stopAllLoaders() + 268 (FrameLoader.cpp:2217)
11  com.apple.WebKit         	0x00343080 -[WebFrame stopLoading] + 92
12  com.apple.WebKit         	0x0038a6f4 -[WebView(WebIBActions) stopLoading:] + 100 (WebView.mm:2513)
13  com.apple.Safari         	0x0004796c 0x1000 + 289132
14  com.apple.Safari         	0x0004776c 0x1000 + 288620
15  com.apple.Safari         	0x000476fc 0x1000 + 288508
16  com.apple.Safari         	0x00047690 0x1000 + 288400
17  com.apple.Safari         	0x0007163c 0x1000 + 460348
18  com.apple.AppKit         	0x9383fc4c -[NSApplication sendAction:to:from:] + 108
19  com.apple.Safari         	0x0002956c 0x1000 + 165228
20  com.apple.AppKit         	0x9389a4b8 -[NSMenu performActionForItemAtIndex:] + 392
21  com.apple.AppKit         	0x9389a23c -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 104
22  com.apple.AppKit         	0x93899ce4 -[NSMenu performKeyEquivalent:] + 272
23  com.apple.AppKit         	0x93899930 -[NSApplication _handleKeyEquivalent:] + 328
24  com.apple.AppKit         	0x937a3408 -[NSApplication sendEvent:] + 2944
25  com.apple.Safari         	0x00021238 0x1000 + 131640
26  com.apple.AppKit         	0x9379ad10 -[NSApplication run] + 508
27  com.apple.AppKit         	0x9388b87c NSApplicationMain + 452
28  com.apple.Safari         	0x0005c77c 0x1000 + 374652
29  com.apple.Safari         	0x0005c624 0x1000 + 374308

Comment 3 mitz 2007-04-29 03:16:27 PDT
This is bug 13360.
Comment 4 David Kilzer (:ddkilzer) 2007-04-29 03:19:39 PDT
(In reply to comment #3)
> This is bug 13360.

So it is.  Thanks Mitz!



*** This bug has been marked as a duplicate of 13360 ***