Bug 13464 - UNABLE TO FOCUS on NON-FORM ITEMS
Summary: UNABLE TO FOCUS on NON-FORM ITEMS
Status: RESOLVED DUPLICATE of bug 7138
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-23 18:06 PDT by Kanda
Modified: 2007-07-05 21:58 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kanda 2007-04-23 18:06:12 PDT
If we have a table on the web page, when using tab to navigate the table (like excel), on safari, it tabs to the different controls on the page instead of navigating the table like excel.

From the developer connection, we found the following information, but it causes all operations (eg. tabindex) and functions that require focus to not work well on these elements.

onFocus
<element onFocus="handler(/args/);" ...>

Discussion

Called when the associated element receives keyboard input focus. Can only be used with elements that can receive keyboard input such as |<input>|, |<textarea>|, or |<select>|.

Availability
* Available in Mac OS X v10.2 with Safari 1.0 and later.
* Available in Mac OS X v10.2.7 and later.

This causes all operations (eg. tabindex) and functions that require focus to not work well on these elements
Comment 1 Dave Hyatt 2007-04-23 18:10:19 PDT
Need more information.  Are you talking about links?  Please supply a URL or test case.
Comment 2 Jesse Costello-Good 2007-06-28 10:03:28 PDT
This is a duplicate of 7138.
Comment 3 David Kilzer (:ddkilzer) 2007-07-05 21:58:52 PDT

*** This bug has been marked as a duplicate of 7138 ***