Bug 13450 - Microsoft live search doesn't work
Summary: Microsoft live search doesn't work
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Mac OS X 10.5
: P2 Normal
Assignee: Nobody
URL: http://maps.live.com/
Depends on:
Blocks: 6519
  Show dependency treegraph
Reported: 2007-04-22 14:32 PDT by Gavin Sherlock
Modified: 2008-08-09 12:23 PDT (History)
1 user (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Gavin Sherlock 2007-04-22 14:32:36 PDT
Go to the http://local.live.com/ and it will kick you over to http://intl.local.live.com/, which is useless.  If you set MSIE 6 as your user agent (why no IE 7?), you can get in, and even search, but the search results never display.  There appear to be a bunch of javascript errors in the console, such as:

Null value

I'm not normally one to use Microsoft products unless I can help it, but a friend said the satellite maps were much better than those in Google.  Seems like some bugs need fixing, after which it's an evangelism problem.  Maybe the hitlist (assuming that's still be taken notice of).

Note, it doesn't work properly in Firefox either (
Comment 1 Gavin Sherlock 2007-10-31 22:57:48 PDT
Trying this with the latest nightly (r27337), and spoofing as IE6 (still no IE7 option), everything pretty much works in terms of navigating the map, but if you try to specify at the top of the page to search a category other than businesses, or even click in the search box, the javascript error that happens says:

Value undefined (result of expression a.getClientRects) is not object.

on line 1.

Any search will fail too.  In the case I tried, there were 2 javascript errors:

Can't find variable: menuDropdownOnHide Line 1243


ReferenceError: Can't find variable: __main
http://maps.live.com/Default.aspx   Line 1363

Maybe this could be on the compatibility hitlist, assuming that it will ever be updated or worked on again.
Comment 2 Robert Blaut 2008-02-10 09:18:42 PST
I've checked the page with Webkit r30119 and I the page works for me without spoofing. I mark the bug as WORKSFORME.

Feel free to reopen the bug if you fine any problem with it.
Comment 3 Robert Blaut 2008-02-10 09:26:36 PST
I incorrectly marked the bug as FIXED. The issue is still present, but the issue seems to be duplicate of bug 6519. 
Comment 4 Gavin Sherlock 2008-08-09 12:23:26 PDT
This seems to work fine in r35203 on 10.5.4