What I would like to see is something like the following:
1) Add -[WKUserContentController postMessageWithBody:name:]. Body would take an (NSNumber, NSString, NSDate, NSArray, NSDictionary, or NSNull). Name would be the name of the message handler
(API name are just a suggestion, I'm more concerned about the functionality).
Sounds like a good suggestion. Probably need a way to post a message to a single WKWebView, as well as broadcast messages (WKUserContentControllers can be shared between multiple WKWebViews).
I'm hitting this again when trying to adopt WKWebView. Specifically, I need the ability to easily send an NSDictionary as a object.
Usage (and a better name) might be:
The functionality requested is now encompassed by https://bugs.webkit.org/show_bug.cgi?id=205239 in the WebKit project
As far as when it may or may not be API, that’s a vendor (e.g. Apple) decision that wont be announced in the WebKit project
*** This bug has been marked as a duplicate of bug 205239 ***