Bug 134202 - Catch Obj-C exceptions thrown by _linenPatternImage
Summary: Catch Obj-C exceptions thrown by _linenPatternImage
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Simon Fraser (smfr)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 11:45 PDT by Simon Fraser (smfr)
Modified: 2014-06-23 12:03 PDT (History)
2 users (show)

See Also:


Attachments
Patch (1.95 KB, patch)
2014-06-23 11:46 PDT, Simon Fraser (smfr)
ggaren: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2014-06-23 11:45:53 PDT
Catch Obj-C exceptions thrown by _linenPatternImage
Comment 1 Simon Fraser (smfr) 2014-06-23 11:46:57 PDT
Created attachment 233620 [details]
Patch
Comment 2 Geoffrey Garen 2014-06-23 11:58:18 PDT
Comment on attachment 233620 [details]
Patch

r=me

An exception like this will likely leak memory and/or locks, causing extra memory use or deadlock. Is there a follow-up bug tracking the cause of the exception throw?
Comment 3 Simon Fraser (smfr) 2014-06-23 11:59:11 PDT
Yes, it's tracked by <rdar://problem/17222297>.
Comment 4 Simon Fraser (smfr) 2014-06-23 12:03:02 PDT
https://trac.webkit.org/r170308