I keep copying around CFRunLoopObserver code, including fun constants like the CA commit run loop order.
Let's put this code in one place.
Created attachment 232805 [details]
I'm going to add another use of this soon, that's why I wanted to do this now.
Attachment 232805 [details] did not pass style-queue:
ERROR: Source/WebCore/platform/cf/RunLoopObserver.h:41: The parameter name "callback" adds no information, so it should be removed. [readability/parameter_name] 
Total errors found: 1 in 12 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 232805 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=232805&action=review
> + typedef std::function<void ()> RunLoopObserverCallback;
Maybe the callback should take a RunLoopObserver&?
(In reply to comment #4)
> Maybe the callback should take a RunLoopObserver&?
No need - you can just capture RunLoopObserver.