Bug 133432 - NodeList's length property should be on prototype
Summary: NodeList's length property should be on prototype
Status: RESOLVED DUPLICATE of bug 154051
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-05-31 23:59 PDT by Ryosuke Niwa
Modified: 2016-04-11 00:57 PDT (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryosuke Niwa 2014-05-31 23:59:30 PDT
Right now, WebKit puts "length" property of NodeList on the object itself.
This doesn't match either DOM4 specification (http://www.w3.org/TR/2014/CR-dom-20140508/#interface-nodelist) or Firefox 29's behavior.
Comment 1 Oliver Hunt 2014-06-01 20:47:30 PDT
sadness. fixable, but sadness :(
Comment 2 Ryosuke Niwa 2014-06-01 21:24:11 PDT
I thought this might be a side effect of us having names properties on NodeList but then ordinary named properties don't override attributes in the object's prototype so we should be able to fix it right away.
Comment 3 Ryosuke Niwa 2016-04-11 00:57:32 PDT

*** This bug has been marked as a duplicate of bug 154051 ***