Bug 13341 - keydown/press/up events do not fire for modifier keys
Summary: keydown/press/up events do not fire for modifier keys
Status: RESOLVED DUPLICATE of bug 11696
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 419.x
Hardware: Macintosh OS X 10.5
: P2 Major
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 6628
  Show dependency treegraph
 
Reported: 2007-04-12 08:23 PDT by Sjoerd Mulder
Modified: 2019-02-06 09:03 PST (History)
2 users (show)

See Also:


Attachments
testcase (862 bytes, text/html)
2007-04-12 08:23 PDT, Sjoerd Mulder
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sjoerd Mulder 2007-04-12 08:23:26 PDT
See attached testcase,

1. Give focus to the textarea
2. Press a normal key (works! =>keydown => keypress => keyup, like it should)
3. Press a modifier key (works! but it will report 4 times the mousemove on the body)

Expected:
Like on windows with Firefox and IE it would be expected that the modifier keys also fire the way normal keys are doing e.g. keydown{1} => keypress{1,n} => keyup{1}.

This is the case on:
- Safari 2.0.4 (419)
- Safari 3 (522)
Comment 1 Sjoerd Mulder 2007-04-12 08:23:58 PDT
Created attachment 14020 [details]
testcase
Comment 2 Darin Adler 2007-04-12 11:38:09 PDT
Maybe we can eliminate the mousemove event too; it's currently used to cause things like the status bar message to update.
Comment 3 Alexey Proskuryakov 2007-07-19 05:00:07 PDT
Except for the mousemove issue, this seems to be the same as bug 11696.
Comment 4 Alexey Proskuryakov 2007-12-03 03:33:20 PST
Filed followup bug 16271 for mousemove.

*** This bug has been marked as a duplicate of 11696 ***
Comment 5 Lucas Forschler 2019-02-06 09:03:34 PST
Mass moving XML DOM bugs to the "DOM" Component.