Bug 133367 - AX: Add support for ARIA 1.1 'none' role
Summary: AX: Add support for ARIA 1.1 'none' role
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 133856 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-28 18:19 PDT by James Craig
Modified: 2014-06-13 08:44 PDT (History)
10 users (show)

See Also:


Attachments
Patch to add support for the 'none' role in ARIA 1.1 (2.11 KB, patch)
2014-06-04 12:58 PDT, Michael Timbrook
cfleizach: review-
Details | Formatted Diff | Diff
Updated patch with change log (3.32 KB, patch)
2014-06-05 11:53 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
Updated patch with change log (3.32 KB, patch)
2014-06-05 11:54 PDT, Michael Timbrook
timbrook: review+
Details | Formatted Diff | Diff
Updated patch with change log (3.32 KB, patch)
2014-06-05 11:55 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
svn compatible patch (3.29 KB, patch)
2014-06-05 15:58 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
adds aria 'none' role (3.29 KB, patch)
2014-06-05 16:11 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
Added 'none' role (3.50 KB, patch)
2014-06-05 16:28 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
added 'none' role (3.50 KB, patch)
2014-06-05 16:29 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff
added 'none' role (3.49 KB, patch)
2014-06-05 16:33 PDT, Michael Timbrook
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Craig 2014-05-28 18:19:51 PDT
"none" is a synonym of "presentation" in the ARIA 1.1 role list.

http://rawgit.com/w3c/aria/master/spec/aria.html#none
Comment 1 Radar WebKit Bug Importer 2014-05-28 18:20:13 PDT
<rdar://problem/17060103>
Comment 2 Michael Timbrook 2014-06-04 12:58:48 PDT
Created attachment 232493 [details]
Patch to add support for the 'none' role in ARIA 1.1
Comment 3 chris fleizach 2014-06-05 11:00:27 PDT
Comment on attachment 232493 [details]
Patch to add support for the 'none' role in ARIA 1.1

looks good, just include a change log for layout tests and webcore, by running
./Tools/Scripts/prepare-ChangeLog --bug=133367

when you upload the new patch make sure you set review ?
Comment 4 Michael Timbrook 2014-06-05 11:53:17 PDT
Created attachment 232569 [details]
Updated patch with change log
Comment 5 Michael Timbrook 2014-06-05 11:54:09 PDT
Created attachment 232570 [details]
Updated patch with change log
Comment 6 Michael Timbrook 2014-06-05 11:55:28 PDT
Created attachment 232571 [details]
Updated patch with change log
Comment 7 Michael Timbrook 2014-06-05 15:58:42 PDT
Created attachment 232587 [details]
svn compatible patch

Made sure the patch would be accepted by svn
Comment 8 Michael Timbrook 2014-06-05 16:11:34 PDT
Created attachment 232590 [details]
adds aria 'none' role
Comment 9 Michael Timbrook 2014-06-05 16:28:30 PDT
Created attachment 232591 [details]
Added 'none' role
Comment 10 Michael Timbrook 2014-06-05 16:29:19 PDT
Created attachment 232592 [details]
added 'none' role
Comment 11 Michael Timbrook 2014-06-05 16:33:17 PDT
Created attachment 232593 [details]
added 'none' role
Comment 12 WebKit Commit Bot 2014-06-05 17:23:31 PDT
Comment on attachment 232593 [details]
added 'none' role

Clearing flags on attachment: 232593

Committed r169632: <http://trac.webkit.org/changeset/169632>
Comment 13 WebKit Commit Bot 2014-06-05 17:23:36 PDT
All reviewed patches have been landed.  Closing bug.
Comment 14 chris fleizach 2014-06-13 08:44:56 PDT
*** Bug 133856 has been marked as a duplicate of this bug. ***